Menu

Formules [Résolu]

dannyd26 3 Messages postés lundi 11 juin 2018Date d'inscription 13 juin 2018 Dernière intervention - 11 juin 2018 à 15:41 - Dernière réponse : Raymond PENTIER 47327 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 20 octobre 2018 Dernière intervention
- 14 juin 2018 à 01:43
Bonjour,
je suis débutante sur excel, j'ai une colonne A avec des noms, une colonne B avec un menu déroulant, il me faut remplir la colonne C comme suit:
C=X si A= noms 1 et B 1er mot déroulant.
C=Y si A= noms 1 et B 2ème mot déroulant
C=Z si A= noms 1 et B 3ème mot déroulant
ainsi de suite
D=X si A= nom 2 et B 1er mot déroulant
D=Y si A= nom 2 et B= 2ème mot déroulant
etc....

je vous remercie.
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
DjiDji59430 2103 Messages postés samedi 19 avril 2008Date d'inscription 20 octobre 2018 Dernière intervention - 11 juin 2018 à 17:29
2
Merci
Bonjour,
Et si tu mettais ton fichier sur Cjoint.com et donnais le lien sur le forum ??

Merci DjiDji59430 2

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24744 internautes ce mois-ci

Commenter la réponse de DjiDji59430
Vaucluse 22870 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 19 octobre 2018 Dernière intervention - Modifié par Vaucluse le 11/06/2018 à 17:31
1
Merci
Bonjour
pour éviter une collection impressionnante de SI, il faudrait savoir combien vous avez de position pour chacun des menus déroulants, nom et code en B, après quoi on pourra mieux vous aider.
dites nous aussi jusqu'où peut aller le etc...
à vous lire
crdlmnt



dannyd26 3 Messages postés lundi 11 juin 2018Date d'inscription 13 juin 2018 Dernière intervention - 12 juin 2018 à 08:51
Bonjour, pour un nom de document de la liste A j'ai 3 possibilité dans la liste B et 3 dans la liste C et pareils pour tous les documents.
par exemple en A j'ai le doc. nomenclature, en B j'ai 1: complexité faible, 2: complexité moyenne, 3: complexité forte et en C j'ai en 1: 34, 2: 56, 3: 92
voilà j'espère être claire.
en fait il faut que lorsque je rentre le nom du document les autres colonnes se remplissent automatiquement.
voilà
merci pour vos réponses.
Cdlt.
Commenter la réponse de Vaucluse
Vaucluse 22870 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 19 octobre 2018 Dernière intervention - Modifié par Vaucluse le 12/06/2018 à 12:57
0
Merci
Bonjour

pas sur d'avoir compris, (surtout pour l'impact éventuel de la valeur de A) mais on va essayez en supposant que le nom en A n'influe dans la formule que pour signaler qu'il faut calculer la formule en C, sinon la laisser "blanche"
Dans ce cas, pour trois options, on peut proposer les SI
si on se place en ligne 1, en C1:

=SI(OU(A1="";B1="");"";SI(B1="complexité faible";Valeur 1;SI(B1="complexité moyenne";Valeur2;Valeur3)))

dans cet exemple Valeur 1, 2 3 est:
  • sot lune valeur numérique
  • soit une valeur texte , qu'i faudra alors placer entre guillemets
  • soit une adresse de cellule hors champ qui contient le résultat à afficher



une autre version serait:
de placer les textes de B, base du menu déroulant, par exemple en Y1,Y2,Y3
de placer en ligne en Z la valeur à afficher en conséquence de Y

la formule, en C devient:

=SI(A1="";"";SIERREUR(RECHERCHEV(B1;$Y$1:$Z$3;2;0));"")

En tous cas,revenez en complétant vos explications si ça ne convient pas

crdlmnt

dannyd26 3 Messages postés lundi 11 juin 2018Date d'inscription 13 juin 2018 Dernière intervention - 13 juin 2018 à 15:58
Merci pour vos réponses,
un collègue d'une autre agence m'a donné la solution par tel.
et ça marche je vous met les 3 formules.
on a créé 2 autres tableaux
et du 1er tableau on est allé cherché dans les 2 autres.

=SI(D1="";0;RECHERCHEV(CONCATENER(N1;" ";D1);Tableau2;2;FAUX))
=SI(B1=".";".";RECHERCHEV(CONCATENER(C1;" ";D1);Tableau1;5;FAUX))
=SI(OU(I1="-";I1=".");0;F1*I1)

merci encore.

Cdlt.
Danny
Commenter la réponse de Vaucluse
Raymond PENTIER 47327 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 20 octobre 2018 Dernière intervention - 14 juin 2018 à 01:43
-1
Merci
Danny,

désolé, mais il était absolument impossible de trouver ces formules en travaillant à partir de tes explications !
Commenter la réponse de Raymond PENTIER