Menu

Pb cellule excel [Résolu]

- - Dernière réponse :  crocdo - 8 juin 2018 à 12:15
bonjour,

j'ai dans une cellule noté ce type de date/texte : 2018-04-19 00:17:43,"-13,5","7,7"
je voudrais que dans la cellule d'a coté juste le -13.5 soit inscrit
avez vous une idée pour que je sois pas obligée de recopier toutes les valeurs car il y a 18000 lignes au total avec ce même format identique

merci pour votre aide
Afficher la suite 

Votre réponse

4 réponses

Messages postés
321
Date d'inscription
mardi 23 octobre 2007
Dernière intervention
1 juin 2018
24
0
Merci
Bonjour,

Si le chiffre recherché est toujours le premier entre guillemet, il est possible de l'extraire à l'aide de la formule TROUVE.
Cela te donne la position du premier " dans ta chaîne de caractère et après en combinant les formule gauche/droite/nbcar/trouve, ça devrait le faire.

Exemple si ta date/texte est en cellule A1:
=GAUCHE(DROITE(A1;NBCAR(A1)-TROUVE("""";A1;1));5)
Commenter la réponse de nightsheart
0
Merci
merci pour ton aide, la formule fonctionne nickel, par contre lorsque les valeurs sont positives elle s'affiche de cette manière 22", comment faire pour enlever les "?
et une dernière question je souhaiterais récuperer la date sous format date 2018-04-19 00:17:43,"-13,5","7,7"
avez vous une idée?
Raymond PENTIER
Messages postés
47986
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 janvier 2019
15509 -
1) =STXT(A1;TROUVE("""";A1;20)+1;TROUVE("""";STXT(A1;22;99))-1)

2) Oui :
2018-04-19 00:17:43,"-13,5","7,7" n'étant pas une date, tu ne peux pas avoir cette expression au format date !
Commenter la réponse de crocdo
Messages postés
15081
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
4720
0
Merci
Bonjour,

je souhaiterais récuperer la date sous format date
Comme ceci en enlevant le texte :
=TEXTE(GAUCHE(A1;TROUVE(",";A1;20)-1);"jj/mm/aaaaa hh:mm")
Commenter la réponse de gbinforme
0
Merci
un grand merci à vous tous j'ai pu réaliser ce que je voulais grâce a vous MERCI
Commenter la réponse de crocdo