Menu

Pb cellule excel [Résolu]

crocdo - 1 juin 2018 à 10:23 - Dernière réponse :  crocdo
- 8 juin 2018 à 12:15
bonjour,

j'ai dans une cellule noté ce type de date/texte : 2018-04-19 00:17:43,"-13,5","7,7"
je voudrais que dans la cellule d'a coté juste le -13.5 soit inscrit
avez vous une idée pour que je sois pas obligée de recopier toutes les valeurs car il y a 18000 lignes au total avec ce même format identique

merci pour votre aide
Afficher la suite 

Votre réponse

5 réponses

nightsheart 321 Messages postés mardi 23 octobre 2007Date d'inscription 1 juin 2018 Dernière intervention - 1 juin 2018 à 10:31
0
Merci
Bonjour,

Si le chiffre recherché est toujours le premier entre guillemet, il est possible de l'extraire à l'aide de la formule TROUVE.
Cela te donne la position du premier " dans ta chaîne de caractère et après en combinant les formule gauche/droite/nbcar/trouve, ça devrait le faire.

Exemple si ta date/texte est en cellule A1:
=GAUCHE(DROITE(A1;NBCAR(A1)-TROUVE("""";A1;1));5)
Commenter la réponse de nightsheart
0
Merci
merci pour ton aide, la formule fonctionne nickel, par contre lorsque les valeurs sont positives elle s'affiche de cette manière 22", comment faire pour enlever les "?
et une dernière question je souhaiterais récuperer la date sous format date 2018-04-19 00:17:43,"-13,5","7,7"
avez vous une idée?
Raymond PENTIER 47294 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 octobre 2018 Dernière intervention - 5 juin 2018 à 01:06
1) =STXT(A1;TROUVE("""";A1;20)+1;TROUVE("""";STXT(A1;22;99))-1)

2) Oui :
2018-04-19 00:17:43,"-13,5","7,7" n'étant pas une date, tu ne peux pas avoir cette expression au format date !
Commenter la réponse de crocdo
gbinforme 15099 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 23 juin 2018 Dernière intervention - 5 juin 2018 à 08:59
0
Merci
Bonjour,

je souhaiterais récuperer la date sous format date
Comme ceci en enlevant le texte :
=TEXTE(GAUCHE(A1;TROUVE(",";A1;20)-1);"jj/mm/aaaaa hh:mm")
Commenter la réponse de gbinforme
0
Merci
un grand merci à vous tous j'ai pu réaliser ce que je voulais grâce a vous MERCI
Commenter la réponse de crocdo