Menu

Problème Wordpress (Thème/CSS) [Fermé]

Messages postés
4
Date d'inscription
mardi 28 novembre 2017
Statut
Membre
Dernière intervention
27 mai 2018
-
Bonjour à tous,

J'ai un problème concernant un site wordpress.
J'ai installer un thème sur celui ci mais je le créer de A à Z avec un page builder (elementor en l'occurence)
Le problème que je rencontre est le suivant :

Il y a un espace entre le menu et le debut de mon site. J'ai inspecter l'élément, pour voir de quoi il s'agissait et voila le résultat :

Cet espace est du à un élément header, qui a un style : margin-bottom:75px

Voici le code html :
<header id="masthead" style="margin-bottom: 75px;" class="site-header logo-left-menu-right header-sticky header-sticky-desktop header-sticky-style-half-slide header-sticky-tablet header-sticky-mobile header-navigation-default headroom headroom--top headroom--not-bottom" role="banner">


Je me suis donc naturellement dit qu'il suffisait de modifier le code du thème pour corriger ce problème, en remplaçant la valeur du "margin-bottom:75px" par 0.

Mais voici le code :


Il n'est aucunement question d'un quelconque margin-bottom.

Le code du thème:
<header id="masthead" class="site-header <?php suffice_header_class(); ?>" role="banner">


Lorsque j'inspecte l'élément je n'ai qu'une interpretation, un retour serveur de mon site.

Donc mes questions sont les suivantes :
Comment corriger ce problème ?
Ou se cache la ligne margin-bottom:75px dans le code/dans les fichiers wordpress de mon site
Comment la modifier ?
Ou la trouver ?
Comment se fait-il qu'une balise <style> vienne se glisser comme ca alors qu'on ne l'appelle nulle part dans le code ?

Je vous laisse constater le problème par vous même : https://elens.fr/

Merci d'avance !
Afficher la suite 

1 réponse

Messages postés
1663
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
4 mai 2019
293
0
Merci
Salut,

Je n'ai pas le souci lorsque je suis allé sur le site, les éléments sont correctement disposés (Opéra 53, idem sur Chrome 66). As-tu bien fait un ctrl+F5 pour forcer à rafraichir le cache de la page ?


Les attributs rajoutés sont fait par un script js : suffice-custom.min.js Pour les retrouver, il est possible d'ajouter un "break on > attributes" sur l'élément, ce qui met en pause l'endroit ou le script a modifié un attribut. Ensuite, on peut retrouver que l'élément est modifié à partir de sa classe, il reste juste à la trouver quelque part dans le bon fichier (avec la fonction "search in all files" dans la liste des sources).

Hydr0s
Messages postés
1663
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
4 mai 2019
293 -
PS : sympa le site ^^