Menu

Choix de feuille puis recherche V selon un mois. [Résolu]

Tab - 16 mai 2018 à 21:06 - Dernière réponse :  Tab
- 17 mai 2018 à 20:54
Bonjour tout le monde,

J'ai un fichier excel dans lequel se trouve plusieurs feuilles dans lesquelles j'ai des données statistiques par rapports à mes opérations et mes clients.

Dans une feuille, j'ai créé un tableaux qui utilise une fonction de rechercheV afin de trouver les données à afficher en fonction du mois qui a été choisi dans un menu déroulant). Je peux donc changer le mois et obtenir les statistiques de ce nouveau mois.

Ceci dit, j'aimerais également y ajouter un menu déroulant afin de choisir le client.

Donc dans un premier temps, je choisi le client (ce qui défini la feuille où effectuer la rechercheV ) et dans un deuxième temps je choisi le mois.

Pouvez-vous m'aider?
Afficher la suite 

Votre réponse

3 réponses

PHILOU10120 5054 Messages postés lundi 16 avril 2012Date d'inscriptionContributeurStatut 15 août 2018 Dernière intervention - 17 mai 2018 à 10:18
0
Merci
Bonjour Tab

Une idée

=SIERREUR(RECHERCHEV($A$1;INDIRECT("'"&$B$1&"'"&"!$A$1:$b$1000");2;0);"")

A1= le mois à chercher
B1=le nom de la feuille dans laquelle chercher
On cherche en colonne A ligne 1 à 1000 et on affiche les données de la colonne B de 1 à 1000

Bonne utilisation
Commenter la réponse de PHILOU10120
gbinforme 15099 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 26 juillet 2018 Dernière intervention - 17 mai 2018 à 10:31
0
Merci
Bonjour,

Dans ta rechercheV il te faut utiliser INDIRECT pour te positionner sur la bonne feuille par exemple :
=RECHERCHEV(A2;INDIRECT(A1&"!A1:B100");2;0)

avec ta feuille en A1 et ton mois en A2 : à toi d'adapter.
Commenter la réponse de gbinforme
0
Merci
Super merci! Ça fonctionne!
Commenter la réponse de Tab