Menu

Somme de n cases par n cases ss google sheet [Résolu]

Harrel 8 Messages postés jeudi 10 mai 2018Date d'inscription 16 juillet 2018 Dernière intervention - 10 mai 2018 à 17:02 - Dernière réponse : Raymond PENTIER 46592 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 août 2018 Dernière intervention
- 14 mai 2018 à 04:21
Bonjour, Bonsoir,

Je suis bloqué depuis des heures à chercher une méthode (formule simple) pour additionner 3 cellules et tirer vers le bas pour qu'il additionne, non pas juste une cellules en dessous mais 3 cellules en dessous.
En clair, je veux additionner 3 cases puis 3 cases suivantes verticalement.

J'ai mis un exemple en pièce jointe : https://www.cjoint.com/c/HEkpbqLFnGP

J'ai essayé avec une fonction =somme(decaler()) mais ça marche que pour la premier case dès que je tire vers le bas ça marche pas.

Help please
Afficher la suite 

Votre réponse

14 réponses

Meilleure réponse
eriiic 21886 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 16 août 2018 Dernière intervention - Modifié par eriiic le 11/05/2018 à 22:42
3
Merci
Bonjour,

=SOMME(DECALER($A$2;(LIGNE()-2)*3;;3))

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci

Merci eriiic 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24699 internautes ce mois-ci

Commenter la réponse de eriiic
Raymond PENTIER 46592 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 août 2018 Dernière intervention - 12 mai 2018 à 00:34
2
Merci
... et pour mettre tout le monde d'accord, voici une solution directe, inspirée de yclik, et conforme à la demande de Harrel :
=SOMME(INDIRECT("A"&3*LIGNE()-4):INDIRECT("A"&3*LIGNE()-2))
Harrel 8 Messages postés jeudi 10 mai 2018Date d'inscription 16 juillet 2018 Dernière intervention - 12 mai 2018 à 02:14
Wahou, je ne m'attendais pas à autant d'aide pour une si petite chose.
Merci mille fois à tous.

Mais heu... Je ne suis pas sarcastique lol ^^
Oui effectivement je n'y avais pas pensé qu'il pouvait glisser de 3 en 3, je reconnais, c'était un peu stupide de ma part.

Merci beaucoup eriiic, tu es mon sauveur, je peux avoir une explication de LIGNE()-2*3 ?
Je ne suis loin d'être aussi calé que vous et je ne comprend pas trop ce qu'il fait de ça...
Le reste, je l'ai compris.

Et merci aussi à Raymond PENTIER, je ne comprend pas du tout ta formule mais elle fonctionne.

Je vais, de ce pas, mettre en résolu ma toute première question sur ce site qui m'a tant servis à maintes reprises.

Cordialement
Raymond PENTIER 46592 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 août 2018 Dernière intervention - 12 mai 2018 à 06:49
Harrel, c'est typique de la part de personnes qui ne sont pas trop "calées" que de croire que tout est possible et que n'importe quoi est évident en bureautique.
C'est une attitude que je rencontre souvent auprès de cadres qui exigent de leurs employés ou stagiaires des choses invraisemblables, pour lesquelles ils voudraient n'avoir qu'à appuyer sur un bouton.
C'est ainsi que ton propos " C'est hallucinant de ne pas pourvoir faire ça de façon simple " dénote une méconnaissance des capacités du logiciel ... et maintenant que tu as les formules, tu te rends compte qu'elles ne s'obtiennent pas spontanément. Sache que j'ai passé un bon moment et fait de nombreux essais avant d'arriver à la formule idoine !

En C4 (ligne 4), je veux écrire que le résultat est =SOMME(A8:A10)
Tu as demandé des calculs de 3 en 3.
J'observe qu'en C2 (ligne 2) c'était =SOMME(A2:A4)
De même en C3 (ligne 3) c'était =SOMME(A5:A7)
et en C4 (ligne 4) ce sera =SOMME(A11:A13)

Examinons C3 :

Pour dire à Excel de lire le contenu de la cellule A5 j'écris INDIRECT("A" & 5)
Or 5 est égal à 3 fois 3 (le N° de la ligne active) moins 4.

Pour lire le contenu de A7 je dois écrire INDIRECT("A" & 7)
et 7 est égal à 3 fois 3 moins 2

Ces règles sont les mêmes pour toutes les lignes, ce qui explique cette formule commune à toutes les cellules en colonne C :
=SOMME ( INDIRECT("A" & 3*LIGNE()-4) : INDIRECT("A" & 3*LIGNE()-2) )
qui s'écrit en réalité sans aucun espace :
=SOMME(INDIRECT("A"&3*LIGNE()-4):INDIRECT("A"&3*LIGNE()-2))
Raymond PENTIER 46592 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 août 2018 Dernière intervention - 12 mai 2018 à 06:55
Tu as donc compris que quand eriiic écrit LIGNE()-2*3 cela veut dire qu'Excel lit le N° de ligne dans laquelle se trouve la formule, retranche 2 et multiplie la différence par 3.
Ainsi en supposant que la formule soit en cellule C3, on aura (3-2)*3 qui donne 3 ...
Harrel 8 Messages postés jeudi 10 mai 2018Date d'inscription 16 juillet 2018 Dernière intervention - 12 mai 2018 à 17:19
Merci, j'ai hésité avant de vous répondre... M.PENTIER Raymond

Votre premier paragraphe ne me semble pas nécessaire, cela est typique des personnes retraitées qui veulent inoculer leurs connaissances et leurs expériences qui leurs semblent plus grande que la moyenne. Apprendre à déchiffrer le langage textuelle est certes pas aisé, je le conçois, mais je tiens à vous spécifier que c'était une forme d'humour de ma part (les phrases que vous avez, semble t il, mal prises).
"C'est hallucinant de ne pas pourvoir faire ça de façon simple" : cette phrase était, non pas pour dénoncer les capacités du logiciel (il ne m'a rien fait : rire) mais les personnes qui ont eu l'intelligence de fabriquer ce type de logiciel mais qui laissent une aide google très précaire (les exemples des formules sont mal expliquer pour les novices comme moi, je trouve).

"et maintenant que tu as les formules, tu te rends compte qu'elles ne s'obtiennent pas spontanément" : ah bon, pourtant, je ne me souviens pas avoir dis ce genre de chose, il semblerait que vous savez mieux que moi ce que je peux penser ou ressortir ou savoir ??

"Sache que j'ai passé un bon moment et fait de nombreux essais avant d'arriver à la formule idoine !" : je n'en doute pas et je vous en remercie du fond du cœur. Sachez que moi aussi j'ai passé quelques heures à chercher sans succès, d'où ma présence sur ce site. Oui comme vous l'aviez spécifié, je ne suis pas "calé" dans ce domaine, je dois peut être m'en excuser ?

Je n'ai en aucun cas voulu être irrespectueux envers qui que ce soit et encore moins envers le logiciel qui me dépasse de loin en mathématique (humour).

L'âge ne fait pas forcément un bon adage.

C'est nouveau ça vient de sortir
Raymond PENTIER 46592 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 août 2018 Dernière intervention - 14 mai 2018 à 04:21
Merci, j'ai pris bonne note.
Et, malgré mon âge avancé, je continue à apprendre, y compris en savoir-vivre ...
Commenter la réponse de Raymond PENTIER
PapyLuc51 1603 Messages postés dimanche 3 mai 2009Date d'inscription 13 août 2018 Dernière intervention - Modifié par PapyLuc51 le 10/05/2018 à 18:53
0
Merci
Bonjour,

Tu tiens absolument que les totaux soit l'un au-dessous de l'autre ?

Sinon, une proposition simplissime :

en B4 tu mets =somme(A2:A4)

Tu sélectionnes les trois cellules B2, B3 et B4 et avec la poignée de recopie, tu incrémentes vers le bas. En B7 il y aura la somme de A5, A6 et A7 ; en B10 la somme de A8, A9 et A10 ; etc......

Cordialement
Harrel 8 Messages postés jeudi 10 mai 2018Date d'inscription 16 juillet 2018 Dernière intervention - 10 mai 2018 à 19:10
Merci déjà pour ta réponse et oui je connais cette astuce mais pas optimal pour mon tableau qui présente une centaine de ligne de données...
Commenter la réponse de PapyLuc51
yclik 1341 Messages postés vendredi 25 juillet 2014Date d'inscription 14 août 2018 Dernière intervention - 10 mai 2018 à 18:49
0
Merci
Bonsoir
a tester
en C2
=INDIRECT("A"&LIGNE())+INDIRECT("A"&LIGNE()+1)+INDIRECT("A"&LIGNE()+2)

en c3 vide
en C4 vide
Sélectionner C2à C4
tirer vers le bas de 3 cellule en 3 cellules
Commenter la réponse de yclik
Harrel 8 Messages postés jeudi 10 mai 2018Date d'inscription 16 juillet 2018 Dernière intervention - 10 mai 2018 à 19:21
0
Merci
Effectivement, je ne veux pas d'espace entre les totaux. Et je ne me vois pas tirer de 3 cellules en 3 cellules, j'ai plusieurs colonnes à faire.

Mon tableau d'origine présente une centaine de données et je veux voir facilement mes totaux de 3 cellules.
Et aussi pour plus tard, ça pourrait me resservir.

C'est hallucinant de ne pas pourvoir faire ça de façon simple ^^, je suis quand même pas le seul gland à vouloir faire ça xd
Raymond PENTIER 46592 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 août 2018 Dernière intervention - 12 mai 2018 à 00:10
Harrel, bonjour.

Tu m'as l'air un peu sarcastique, mais tu ne réfléchis pas suffisamment ...
" je ne me vois pas tirer de 3 cellules en 3 cellules "
Et si, tout bêtement, tu sélectionnais les 3 cellules C3:C4 et tu utilisais la poignée (bouton en bas à droite de la sélection) pour tirer vers le bas sur une centaine de lignes d'un seul coup ? https://www.cjoint.com/c/HElwjnRZP7K
eriiic 21886 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 16 août 2018 Dernière intervention - 12 mai 2018 à 00:16
Et accessoirement une réponse susceptible de t'intéresser est remontée en haut.
eric
Commenter la réponse de Harrel
PapyLuc51 1603 Messages postés dimanche 3 mai 2009Date d'inscription 13 août 2018 Dernière intervention - Modifié par PapyLuc51 le 11/05/2018 à 18:54
0
Merci
Bonjour
Faute de mieux un exemple avec des données hors champs

https://www.cjoint.com/c/HElqSWrWcEH

Cordialement
Commenter la réponse de PapyLuc51