Menu

Sftp dans un script shell

- - Dernière réponse : Char Snipeur
Messages postés
9702
Date d'inscription
vendredi 23 avril 2004
Statut
Contributeur
Dernière intervention
3 juillet 2018
- 10 juin 2018 à 20:38
Bonjour,

je suis sur AIX 7.1 , je voudrais mettre en place un script qui fait le dépôt de fichiers via sftp , mais il me demande toujours le mot de passe , j'ai essayé ca
export HOST=XXXXX
export USER=XXXXX
export PASSWD=XXXXX


sftp<<END_SCRIPT
sftp -P "n°du port" $USER@$HOST
echo "$PASSWD"
END_SCRIPT


sans succès.


Si qlq a une idée ...

Merci beaucoup


Afficher la suite 

Votre réponse

4 réponses

0
Merci
salut,

sftw : ssh échange de clés publiques
Commenter la réponse de Utilisateur anonyme
0
Merci
Bonjour et merci pour la reponse.

Mais la connexion est dejas faite en ligne de commande les cles sont deja echangés
sftp -P "n° du port" "USER"@HOST
zipe31
Messages postés
36087
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
13 janvier 2019
5693 -
Salut,

Et je suppose que tu as mis une "passphrase" quand tu as créé tes clés ? ;-\
Commenter la réponse de dino
0
Merci
Bonjour ,

Désolé , pour le retard ...pris par d'autres sujets boulot !

non je n'ai pas mis le "passphrase" , les cles sont crées automatiquement a la premiere connexion en ligne de commande

Merci
Utilisateur anonyme -
si l'utilisateur qui exécute le script n'est pas l'utilisateur qui se connecte au serveur, les clés recherchées dans le répertoire de l'utilisateur_qui_exécute_le_script ne correspondent pas, et donc le mot de passe est demandé.
Exileur
Messages postés
1333
Date d'inscription
mercredi 31 août 2011
Dernière intervention
13 octobre 2018
91 -
ça ce vérifie sur le serveur dans /var/log/auth.log
Commenter la réponse de dino
Messages postés
9702
Date d'inscription
vendredi 23 avril 2004
Statut
Contributeur
Dernière intervention
3 juillet 2018
1628
0
Merci
ssh-copy-id ne fonctionne pas?
Commenter la réponse de Char Snipeur