Menu

Condition SI et SI.CONDITIONS sur excel 2010 [Résolu]

SOSO - 9 mai 2018 à 09:54 - Dernière réponse : Vaucluse 22590 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 13 août 2018 Dernière intervention
- 14 mai 2018 à 17:13
Bonjour tout le monde,

Je cherche à créer un nouveau titre que j'effectue par concaténation . Sauf que pour être référencé, ce titre doit contenir 70 caractères maximum en T145.

J'aimerais exprimer 3 conditions :

1. Si NB.CAR(T145<69) -> afficher la concaténation la plus longue : "buy" + colonne H qui représente le titre du produit + colonne B qui représente la catégorie du produit

2. Si NB.CAR(T145 >90), afficher que la colonne H ( c'est à dire supprimer le "buy"

3 Entre 70 et 90 : afficher colonne H et B


La fonction SI qui en découle :
=SI(NBCAR(T145)<69;"Buy"&" "&H145&" "&"("&B145&")";SI(NBCAR(T145)>90;H145; SI(ET(T145>=70;T145<=90);H145&" "&"("&B145&")";"ok")))


Problèmes :
--> quand j'entre la fonction et que la cellule contient 82 caractères, la cellule affiche "ok" ... alors qu'entre 70 et 90 caractères, T145 devrait contenir la concaténation H145 et B145

--> J'utilise excel 2010 mais le SI.CONDITIONS disponible sur Excel 2016 est peut être transposable ?

Si je ne suis pas claire n'hésitez pas à me le dire
Afficher la suite 

Votre réponse

5 réponses

PHILOU10120 5053 Messages postés lundi 16 avril 2012Date d'inscriptionContributeurStatut 14 août 2018 Dernière intervention - 9 mai 2018 à 10:12
0
Merci
Bonjour

Essayer cette formule

=SI(NBCAR(T145)<70;"Buy"&" "&H145&" "&"("&B145&")";SI(NBCAR(T145)>90;H145; SI(OU(T145>=70;T145<=90);H145&" "&"("&B145&")";"ok")))
Commenter la réponse de PHILOU10120
Vaucluse 22590 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 13 août 2018 Dernière intervention - Modifié par Vaucluse le 9/05/2018 à 10:40
0
Merci
Bonjour
on peut peut être économiser quelques & et guillments mêm si ça ne nuit pas au fonctionnement

=SI(NBCAR(T145)=0;"ok";SI(NBCAR(T145)<70;"Buy "&H145&" ("&B145&")";SI(NBCAR(T145)<91;H145&" ("&B145&")";H145)))

attention aux limites , par exemple si on écrit <69 et69 ne sera pas inclus (ect..)

crdlmnt

Vaucluse 22590 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 13 août 2018 Dernière intervention - 14 mai 2018 à 17:13
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse