Menu

Liste déroulante pour sélectionner une feuille [Résolu]

mathieu4012 4 Messages postés mercredi 11 avril 2018Date d'inscription 12 avril 2018 Dernière intervention - 11 avril 2018 à 08:45 - Dernière réponse : Raymond PENTIER 46367 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 21 juillet 2018 Dernière intervention
- 17 avril 2018 à 01:31
Bonjour,

Je réalise actuellement un fichier Excel afin de suivre le taux de rendement synthétique d'un site de production cependant je me heurte à un problème. Le site dispose de 4 presses qui ont chacune une feuille Excel identique seules les valeurs changes je souhaiterai donc que vous m'indiquiez comment créer une liste déroulante contenant les noms des feuilles et que ce choix modifie la page prise en compte dans les calcul exemple ci dessous.

Merci à l'avance.

=+SOMME.SI.ENS('PRESSE 1'!$M$4:$M$3000;'PRESSE 1'!$A$4:$A$3000;$B$12;'PRESSE 1'!$O$4:$O$3000;C28)

Afficher la suite 

Votre réponse

9 réponses

Meilleure réponse
Patrice33740 7121 Messages postés dimanche 13 juin 2010Date d'inscription 21 juillet 2018 Dernière intervention - Modifié par Patrice33740 le 11/04/2018 à 09:11
1
Merci
Bonjour,

Si la liste déroulante (validation de données) est en A1, avec une formule employant INDIRECT() :
=SOMME.SI.ENS(INDIRECT("'" & A1 & "'!$M$4:$M$3000");INDIRECT("'" & A1 & "'!$A$4:$A$3000");$B$12;INDIRECT("'" & A1 & "'!$O$4:$O$3000");C28) 


Cordialement
Patrice

Merci Patrice33740 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 22599 internautes ce mois-ci

mathieu4012 4 Messages postés mercredi 11 avril 2018Date d'inscription 12 avril 2018 Dernière intervention - 11 avril 2018 à 09:43
Bonjour Patrice ,

Je tenais tout d'abord à vous remercier pour votre réponse qui résout mon premier problème cependant malgré mes recherches je ne sais pas comment créer une liste déroulante permettant de sélectionner mes feuilles ('PRESSE 1'!)('PRESSE 3'!)('PRESSE 4'!)('PRESSE 5'!). Pourriez vous me l'expliquer ?

Merci pour votre aide par avance.
Patrice33740 7121 Messages postés dimanche 13 juin 2010Date d'inscription 21 juillet 2018 Dernière intervention - 12 avril 2018 à 08:46
PS : Avec la formule précédente, la liste déroulante ne doit contenir ni apostrophe ni point d'exclamation soit, dans la case source :
PRESSE 1;PRESSE 3;PRESSE 4;PRESSE 5
Commenter la réponse de Patrice33740
Meilleure réponse
Raymond PENTIER 46367 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 21 juillet 2018 Dernière intervention - 11 avril 2018 à 21:38
1
Merci
Bonjour.
Plutôt qu'une liste déroulante, il serait beaucoup plus pratique et approprié d'insérer des liens hypertexte.

Merci Raymond PENTIER 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 22599 internautes ce mois-ci

Patrice33740 7121 Messages postés dimanche 13 juin 2010Date d'inscription 21 juillet 2018 Dernière intervention - 12 avril 2018 à 08:52
Bonjour Raymond

Les liens ne conviendront pas : « comment créer une liste déroulante [...] et que ce choix modifie la page prise en compte dans les calcul ...»

Cordialement
Patrice
Raymond PENTIER 46367 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 21 juillet 2018 Dernière intervention - 17 avril 2018 à 01:31
Exact ...
Commenter la réponse de Raymond PENTIER
mathieu4012 4 Messages postés mercredi 11 avril 2018Date d'inscription 12 avril 2018 Dernière intervention - Modifié par mathieu4012 le 12/04/2018 à 09:03
0
Merci
Bonjour ,

J'ai crée des liens hypertextes comme vous me l'avez conseillé cependant je n'arrive pas à faire fonctionner la formule j’obtiens une erreur #REF. Je vous joins une capture d'écran pour vous aider a comprendre le problème.
Merci d'avance pour votre aide !

Commenter la réponse de mathieu4012
mathieu4012 4 Messages postés mercredi 11 avril 2018Date d'inscription 12 avril 2018 Dernière intervention - 12 avril 2018 à 10:15
0
Merci
Bonjour,

j'ai enfin réussi à tout faire fonctionner grâce a vos conseils je vous remercie de m'avoir aidé tous les 2
Commenter la réponse de mathieu4012