Menu

Formule SI imbriqué avec fonctions Index Equiv [Résolu]

Messages postés
13
Date d'inscription
vendredi 6 avril 2018
Dernière intervention
7 janvier 2019
- - Dernière réponse : gbinforme
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
- 6 avril 2018 à 10:28
Bonjour,

Je cherche à imbriquer 3 fonctions SI avec les fonctions INDEX EQUIV comme s’ensuit :

=SI(Q2="4";(INDEX('GA300'!$1:$1048576;EQUIV(P2;'GA300'!$A:$A;0)+3;EQUIV($R$1;'GA300'!$1:$1;0)));0);
=SI(Q2="3";(INDEX('GA300'!$1:$1048576;EQUIV(P2;'GA300'!$A:$A;0)+2;EQUIV($R$1;'GA300'!$1:$1;0)));0);
=SI(Q2="2";(INDEX('GA300'!$1:$1048576;EQUIV(P2;'GA300'!$A:$A;0)+1;EQUIV($R$1;'GA300'!$1:$1;0)));0)

Pourriez-vous me donner la bonne formulation?

Merci par avance
Afficher la suite 

Votre réponse

1 réponse

Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
4766
0
Merci
Bonjour,

Comme ceci tu devrais avoir satisfaction :
=SI(ET(Q2>=2;Q2<=4);(INDEX('GA300'!$1:$1048576;EQUIV(P2;'GA300'!$A:$A;0)+Q2-1;EQUIV($R$1;'GA300'!$1:$1;0)));0)
Commenter la réponse de gbinforme