Menu

Transfert de données entre feuilles [Fermé]

Messages postés
165
Date d'inscription
mardi 24 avril 2012
Statut
Membre
Dernière intervention
21 mai 2019
- - Dernière réponse : PHILOU10120
Messages postés
5329
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
24 juin 2019
- 27 mars 2018 à 09:28
Bonjour,

Dans un classeur je possède deux feuilles. Dans la première j'inscris des montants classés par types (alimentation, gaz, électricité... etc). J'ai installé une liste de validation de données sur chaque ligne de montant pour les classer facilement grâce à une liste déroulante.

Sur la seconde feuille je retrouve le listing des types de classification. Ce que j'aimerais c'est que lorsque sur la première feuille je sélectionne par exemple "alimentation" pour un montant de 38,00 €, ce montant soit automatiquement affiché sur la seconde feuille dans la cellule "alimentation". Et que ce montant s'additionne dans la seconde feuille à chaque fois que je sélectionne un nouveau montant dans la première feuille.

J'espère être clair.

Merci d'avance.

Afficher la suite 

2 réponses

Messages postés
5329
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
24 juin 2019
318
0
Merci
Bonjour YameFAZE

Essayer ceci

=SOMME.SI(Feuil1!A1:A100;A4;Feuil1!B1:B100)
Feuille 1
colonne A les familles de dépenses (alimentation)
colonne B la valeur

Sur la feuille 2
colonne A = familles de dépenses ici en A4 = alimentation
colonne B = la formule

la formule est faite pour les 100 première lignes
Messages postés
165
Date d'inscription
mardi 24 avril 2012
Statut
Membre
Dernière intervention
21 mai 2019
0
Merci
Merci mais je crois que je me suis mal exprimé... je vais essayer de faire simple.

- Feuille 1 :
- Cellule A1 : Liste déroulante avec en choix "alimentation" ou "essence"
- Cellule B1 : 38,00 Euros

- Feuille 2 :
- Cellule A1 : "alimentation"
- Cellule B1 : "total alimentation"
- Cellule A2 : "essence"
- Cellule B2 : "total essence"

J'aimerais que, si dans la cellule A1 de la feuille 1 je sélectionne "alimentation" la valeur "38,00 Euros" aille dans la cellule B1 de la feuille 2, et si dans la cellule A1 de la feuille 1 je sélectionne "essence" la valeur "38,00 Euros" aille dans la cellule B2 de la feuille 2. Et j'aimerais que les cellules B1 et B2 de la feuille 2 additionnent leur total à chaque fois que je sélectionne sur la feuille 1 une valeur supplémentaire avec "alimentation" ou "essence". Chaque ligne de la feuille 1 possède sa cellule avec la liste déroulante, et au bout de chacune de ces lignes, se trouve une autre cellule avec une valeur.
PHILOU10120
Messages postés
5329
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
24 juin 2019
318 -
Pour faire ce que vous demandez il faudra une macro qui copie l'information puis va la placer sur l'autre feuille en B2 et après en B3 pour la donnée suivante et ainsi de suite