Menu

Faire un produit de 2 colonnes avec 2 conditions [Résolu]

marie21lc 4 Messages postés mercredi 14 mars 2018Date d'inscription 14 mars 2018 Dernière intervention - 14 mars 2018 à 11:07 - Dernière réponse : Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention
- 14 mars 2018 à 12:45
Bonjour,
j'ai une difficulté :

dans une première page excel j'ai 2 colonne A et B avec des conditions
colonne A = Trés fréquente /fréquente/...
colonne B = Très grave / Grave / etc

Dans une seconde page excel : j'ai accordé des points en fonction
Très fréquente = 16
Fréquente = 12
Très grave = 16
Grave = 12

Je souhaiterais faire le produit suivant :
si colonne A contient Très fréquent et colonne B contient Très grave, faire le produit correspondant à savoir ici = 16*16
ou encore si colonne A contient Très fréquent et colonne B Grave, faire le produit correspondant à savoir ici = 16*12

Merci pour votre aide.
Afficher la suite 

Votre réponse

6 réponses

Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - Modifié par Vaucluse le 14/03/2018 à 11:41
0
Merci
Bonjour

ça devrait pouvoir se faire avec une fonction de recherche:
à adapter
en feuil2 de A1 à B4; le tableau A1 à A2 les codes de A et B1:B2, les codes de B et C1:C21 à C24 les valeurs correspondantes 16 et 12
en feuil2 de C1 à C4 les codes de et B1 à B4 les valeurs correspondantes

édition en feuille 1en C2

=SI(OU(A2="";B2="");"";RECHERCHEV(A2;Feuil2!$A$1:$B$4;3;0)*(RECHERCHEV(B2;Feuil2!$C$1:$B$4;2;0))


bien entendu, vous pouvez agrandir le tableau de feuil2!selon vos conditions et modifier en conséquences les adresses dans la formule


ou avec conditions, mais un peu lourd s'il y en a beaucoup:

=SI(OU(A2="";B2="");"";SI(A2="Très fréquent";16;SI(A2="fréquent";12)*SI(B2="Très grave";16;B2="grave";12)

la condition évite un affichage d'erreur si une des deux cellules est vide
mais renvoie une erreur si une cellule A ou B contient autre chose que les textes prévus.


crdlmnt


marie21lc 4 Messages postés mercredi 14 mars 2018Date d'inscription 14 mars 2018 Dernière intervention - 14 mars 2018 à 12:33
Bonjour,
J'ai fait avec la première formule avec si & ou et j'ai réussi !! Merci beaucoup pour votre aide, je n'avais pas pensé à la recherchev!
Bonne fin de journée!
Commenter la réponse de Vaucluse
PHILOU10120 5000 Messages postés lundi 16 avril 2012Date d'inscriptionContributeurStatut 19 juin 2018 Dernière intervention - 14 mars 2018 à 11:40
0
Merci
Bonjour

Une idée dans le fichier

https://www.cjoint.com/c/HCokOxM8BJx
marie21lc 4 Messages postés mercredi 14 mars 2018Date d'inscription 14 mars 2018 Dernière intervention - 14 mars 2018 à 12:35
Pas mal aussi ! je ne connaissais pas cette formule ! merci beaucoup !
Commenter la réponse de PHILOU10120
marie21lc 4 Messages postés mercredi 14 mars 2018Date d'inscription 14 mars 2018 Dernière intervention - 14 mars 2018 à 12:35
0
Merci
Merci à tous pour votre aide, j'ai ma réponse!
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 14 mars 2018 à 12:45
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de marie21lc