Menu

Besoin d'aide formule excel [Résolu]

Sam - 13 mars 2018 à 12:38 - Dernière réponse : Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention
- 13 mars 2018 à 17:32
Bonjour,

Je n'arrive pas à trouver la formule dont j'ai besoin:

Année trimestre donnée
2017 1 0.23
2017 2 0.25
. . .

Existe il une formule pour obtenir la donner en tapant l'année et le trimestre ? (dans une seul case donc pas de si(ET(... possible).

Année: 2017 Trimestre: 2


Donnée: ? (formule ?)

Merci par avance,

Sam


Afficher la suite 

Votre réponse

7 réponses

Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - Modifié par Vaucluse le 13/03/2018 à 13:59
0
Merci
Bonjour
exemple à adapter

base de données:
  • liste des références année + trimestre en A

type d'écriture :
  • année + blanc + trimestre


valeur à ressortir en B
  • année cherchée en C1,
  • trimestre cherché en D1;


édition en E1:
=INDEX(C:C;EQUIV(C1 &" "&D;B:B;2;0))
ou encore
=RECHERCHEV(C1&" "&D1;A:B;2;0)

pour éviter un affichage éventuel d'erreur si C1 et D1 ne contiennent pas des valeurs compatibles avec A (ou vides)
dans les deux cas ( à partir d'Excel 2007)

=SIERREUR(formule);"")

.. sous réserve de bonne compréhension de la question!
si ça ne convient pas, déposez un modèle ici:
http://mon-partage.fr
et revenez coller le lien créé sur le site
à vous lire
crdlmnt




Commenter la réponse de Vaucluse
0
Merci
2017 1 4
2017 2 2
2017 3 3
2017 4 5
2018 1 3
2018 2 0
2018 3 0
2018 4 0
(3 colonnes) La troisième colonne représente la donnée X

Le but étant d'obtenir X en entrant une année et un trimestre dans un formulaire d'un autre onglet, type:

Année 2017 Trimestre 4 (2 cellule, 1 année et 1 trimestre)
x = ? (5)

Je pense ne pas avoir compris ta réponse ou ne pas avoir exprimé clairement mon problème.
Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 13 mars 2018 à 14:26
effectivement, avec le premier message, j'avais cru comprendre que les données de la base étaient dans une seule cellule!

Apparemment ce n'est pas le cas (année en A trimestre en B valeur en C (?))

mais qu'en est il de la valeur cherchée, deux cellules, une seule cellule?
si deux cellules, exemple D1 et C1, cette formule en matricielle:

=INDEX($C$1:$C$100;EQUIV($D$1&$C$1;$A$1:$A$100&$B$1:$B$100;0))

attention formule matricielle à entrer avec la touche enter en maintenant les touches ctrl et shift enfoncées

elle doit s'afficher automatiquement entre accolades dans la barre de formule
le code SIERREUR et utilisable là aussi

cette formule est assez "gournamnde" en capcité, mieux vaut limiter les champs au nombre de ligne utiles (ici 1 à 100)

et si ce n'est pas encore ça, revenz en déposant un modèle.
crdlmnt
https://mon-partage.fr/f/izIsC1G1/

Merci d'avance de ton aide,

Sam
Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 13 mars 2018 à 14:56
Merci beaucoup pour ton aide et ton temps,

Bonne continuation,

Sam
Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 13 mars 2018 à 17:32
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Sam