Menu

Creer une foire aux questions

Nasouka 1 Messages postés jeudi 8 mars 2018Date d'inscription 8 mars 2018 Dernière intervention - 8 mars 2018 à 15:07 - Dernière réponse : Vaucluse 22215 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 juin 2018 Dernière intervention
- 8 mars 2018 à 15:20
Bonjour à toutes et à tous,

On me demande de réaliser une foire aux questions sur un fichier Excel.
On a un fichier REX qui contient plusieurs informations qui pourront être utiles pour d'autres utilisateurs.
L'idée est de faciliter la consultations des informations de ce fichier
Rechercher une information en tapant un mot => on va avoir toutes les lignes correspondantes et à partir de là on doit pouvoir compléter ou modifier une ligne.

Je sais qu'il faut créer un formulaire mais je ne sais pas par où commencer.

Si vous pouvez m'aider, merci d'avance.

Bien à vous.
Afficher la suite 

Votre réponse

1 réponse

Vaucluse 22215 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 17 juin 2018 Dernière intervention - 8 mars 2018 à 15:20
0
Merci
Bonjour

une solution bête si vous avez une colonne avec le total des textes, par exemple en A2:A1000
en B1 entrez le mot cherché
en B2 et sur la hauteur de la liste cette formule:
=SI(NB.SI(A2;"*"&$B$2&"*");1;0)
qui vous renvoie 1sur toutes les lignes contenant le mot (ou le texte plus long)cherché
ensuite, il ne reste qu'à filtrer sur le 1 pour avoir le résultat
(cette solution fonctionne aussi avec la formule dans une condition de MFC et un filtrage sur la couleur)

autre option:

la liste en Feuil1 A2:A1000
en Feuil2 A1 le mot cherché

en Feuil1 B2 la formule sur la hauteur des textes:
=SI(NB.SI(A2;"*"&Feuil2!$A$2&"'*");MAX($B$1:B1)+1;"")
attention aux signes pour tirer sur la hauteur utile

en Feuil2 à partir de A2:
=SIERREUR(INDEX(Feuil1!A:A;EQUIV(LIGNE(A1);Feuil1!B:B;0));"")
à tirer sur la hauteur utile estimée en fonction du nombre maximum de textes ressortant

cette solution vous affichera en feuil2 les textes de Fruil1 qui contiennent le texte en A2

crdlmnt

Commenter la réponse de Vaucluse