Menu

Selection non continue [Résolu]

chat - 8 mars 2018 à 10:26 - Dernière réponse : Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention
- 9 mars 2018 à 17:28
Bonjour,
Pour réaliser une formule, comment sélectionner dans une colonne des cellules non contigües (toutes les six) et 365.
merci


Afficher la suite 

Votre réponse

9 réponses

michel_m 15352 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 19 juin 2018 Dernière intervention - 8 mars 2018 à 10:44
0
Merci
Bonjour
Comment sélectionner dans une colonne des cellules non contigües (toutes les six) et 365.



Toutes les 6, d'accord, mais 365, c'est quoi ?
Bonjour,
Merci de répondre.
... 365 c'est le nombre de celules correspondant à 365 jours, mais elles ne sont pas contigûes, d'autres les séparent.
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 8 mars 2018 à 15:09
Bonjour
tout dépend si vous admettez d'avoir la formule en continu sur toute la colonne ou si vous voulez l'avoir exclusivement sur ces lignes
dans ce second cas, il n'y a pas beaucoup de possibilité, sinon d'y aller graduellement:
  • entrez la formule dans la 1° cellule en bloquant bien ce qui doit être bloqué avec le signe$
  • copier cette cellule
  • sélectionner un groupe de cellule à remplir en maintenat la touche ctrl enfoncée (pas les 364 sinon ça va être pénible, mais en plusieurs fois)
  • et clic droit / coller


crdlmnt
Je n'ai pas su m'expliquer...: Je veux créer une seule cellule, totalisatrice de 365 autres cellules (non contigûes et dans une même colonne, soit une toute les six cellules). Est-ce plus clair?!
Encore merci pour votre attention.
Commenter la réponse de michel_m
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - Modifié par Vaucluse le 8/03/2018 à 17:42
0
Merci
Bonjour

alors une formule matricielle à adapter car on ne connaît pas votre fichier, mais pour faire la somme de A1 à A2000 de toutes les cellules qui sont sur une ligne divisible par 5


=SOMME(SI(MOD(LIGNE($A$1:$A$2000);5)=0;$A$1:$A$2000))

mais tout dépende où se trouve la 1° cellule. Il faut ajuster la formule pour que la somme du correcteur avec le N° de la 1° ligne donne 5

par exemple avec la formule ci dessus, si vous démarrer sur ligne 5
si c'est sur ligne 2

=SOMME(SI(MOD(LIGNE($A$1:$A$2000)+3;5)=0;$A$1:$A$2000))

attention7cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées
elle doit s'afficher automatiquement entre accolades dans la barre de formule

crdlmnt




Commenter la réponse de Vaucluse
0
Merci
Désolé... mais je n'y arrive pas. Je restais assez vague, pour pouvoir adapter(et comprendre) et je n'avais pas tous les éléments devant les yeux. Bref, je veux faire la somme de la cellule B2, B8, B14 etc... jusqu'à la cellule B2186.

Encore merci pour votre patience.
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 8 mars 2018 à 19:19
voyez ici
en fait le pas est de 7 il faut donc que MOD se rapporte à 6

la formule fonctionne jusqu'à ligne 3000

https://mon-partage.fr/f/VKlTzAD4/

crdlmnt
Commenter la réponse de chat
0
Merci
Bonjour,
Mes excuses pour ne pas avoir répondu plus tôt ... trop occupé!
Mais ça y est,votre formule a marché et j'ai pu m'en sortir.
Bravo pour votre savoir exel.
A bientôt et encore merci!
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 9 mars 2018 à 17:28
C'est sans problème
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de chat