Menu

Problème serveur SMTP

snoop13120 217 Messages postés samedi 9 août 2008Date d'inscription 6 avril 2018 Dernière intervention - 8 mars 2018 à 02:35 - Dernière réponse : snoop13120 217 Messages postés samedi 9 août 2008Date d'inscription 6 avril 2018 Dernière intervention
- 10 mars 2018 à 16:18
Bonjour,


J'utilise un logiciel avec lequel je souhaiterais envoyer des emails (logiciel WinCC Siemens), ce logiciel pilote des installations industrielles et permet entre autres de détecter des défauts et d'afficher des fenêtres d'alarmes.

Il est possible via ce logiciel d'envoyer des emails (le contenue des fenêtres d'alarmes), si celui-ci est "relier" à un serveur SMTP, il suffit simplement d'entrer le nom du serveur (localhost ou son IP) + le numéro de port et éventuellement une authentification, mais ce n'est pas obligatoire.

Jusqu'ici tout va bien, le logiciel semble reconaitre le serveur et les messages m'ont l'air de transiter parfaitement vers le serveur (serveur et logiciel sur le même PC), sauf qu'au niveau du serveur SMTP j'ai un problème '"error socket error 60010" cette erreur a l'air connue, j'ai désactivé le blocage des SMTP sortant sur ma freeBox, j'ai ouvert le port 25, j'ai essayé de me connecter au serveur sans authentification, avec authentification, j'ai essayé plusieurs serveur (pas en même temps), notament postcastserver et SMTP server Pro mais rien n'y fait...
Je sens qu'il ne me manque pas grand chose pour y arriver mais je n'ai plus d'idée

Merci d'avance pour vos suggestions, je peux vous poster une copie d'écran du Log du server demain...




Window7
Afficher la suite 

Votre réponse

7 réponses

brupala 76870 Messages postés lundi 16 juillet 2001Date d'inscriptionModérateurStatut 24 juin 2018 Dernière intervention - 8 mars 2018 à 09:05
0
Merci
Salut,
tu as essayé avec le serveur smtp de Free ?
ou tu veux ton propre domaine ?
snoop13120 217 Messages postés samedi 9 août 2008Date d'inscription 6 avril 2018 Dernière intervention - 8 mars 2018 à 19:01
Bonjour,

Non je n'ai pas essayé avec celui de Free, j'ai essayé avec des logiciel qui m'ont été recommandé par le constructeur mais j'ai un message d'erreur..

"error Socket error 60010 connection timed out... Atempt set to.. "

J'aimerais bien poster le Log, mais je ne sais pas comment poster une PJ sur le forum....

Merci pour la réponse
brupala 76870 Messages postés lundi 16 juillet 2001Date d'inscriptionModérateurStatut 24 juin 2018 Dernière intervention > snoop13120 217 Messages postés samedi 9 août 2008Date d'inscription 6 avril 2018 Dernière intervention - 8 mars 2018 à 23:12
Essaie de passer par le smtp de free alors ou d'autres systemes :
Submission sur le port 587
snoop13120 217 Messages postés samedi 9 août 2008Date d'inscription 6 avril 2018 Dernière intervention > brupala 76870 Messages postés lundi 16 juillet 2001Date d'inscriptionModérateurStatut 24 juin 2018 Dernière intervention - 10 mars 2018 à 01:03
Bonjour,

Merci de votre réponse, j'ai testé différent serveur smtp via l'invité de comande en utilisant la comande "telnet" un commande bien pratique (à activer sur window 7) on entre telnet nomserveur port et il teste...

La conclusion est que le FAI bloque a peu prés tout ce qui peu sortir du port 25 sauf smtp.free.fr...
J'ai teste smtp.gmail.com ça avait l'air de passer sur le port SSL 465 mais au final ça ne passe pas.. un peu comme si le fournisseur n'autorisé que son propre domaine.. pas qu'un peu d'ailleurs..

Moralité je vais tenter de passer pas Free, j'ai créer une adresse email, car pour utiliser le serveur il faut s'authentifier, et j'attend que mon compte soit actif pour tester...

Je testerais le port 587, cependant comme je suis en SSL, il semblerait que je sois plutot concerné par le 465.

J'aivais aussi assayer de voir si le problème ne venait pas de mes "socket", apperement ce sont des "connections" virtuelle entre le serveur et le système d'exploitation, il se peut qu'il est un problème de ce côté là et j'ai tenté une commande sur l'invité de commande "netsh winsock reset " au cas où, ça couté pas cher.. Mais rien de neuf..

je pense que tout cela vien du FAI..

Bonne soirée et merci, je vous tiens au courant dés que j'ai accès au serveur Free.
snoop13120 217 Messages postés samedi 9 août 2008Date d'inscription 6 avril 2018 Dernière intervention - 10 mars 2018 à 16:18
Bonjour,

Apparement j'ai réussi hier soir avant de poster... Mais le mail était dans mes spams..
J'ai retenté aujourd'hui avec le serveur de Free et ça marche nickel, comme je suis abonné free, pas besoin de m'authentifier, et pas besoins non plus d'utiliser mon propre serveur...
Concernant le serveur smtp.gmail.com ça ne marche pas, je pense que le FAI bloque tout, et n'autorise les communications sortantes par le port 25 que pour des requêtes sur son propore serveur smtp et encore sous réserve de déselectionné l'option de blocage du courrier smtp sortant dans les options de la Free box.

Merci pour votre soutien, je vais persévérer quand même et essayer de faire fonctionner tout ça avec mon propre serveur car j'en aurait besoins..

J'ai déjà des pistes, comme utiliser dans un premier temps le serveur en local et rediriger vers le serveur SMTP...
Je sais que ça sert à rien mais je dois réaliser cette prestation avec des pupitres industriels qui ne peuvent pas se connecter au Net mais utilise Ethernet en local, l'idée et de les faire communiquer en local dans un premier temps avec un PC qui fera office de serveur en indiquant l'adresse IP et le port et une fois le serveur atteint il redirige vers un smtp et envois les email....

Merci
Commenter la réponse de brupala
snoop13120 217 Messages postés samedi 9 août 2008Date d'inscription 6 avril 2018 Dernière intervention - 8 mars 2018 à 19:02
0
Merci


Voila le Log en espérant qu'il soit lisible
snoop13120 217 Messages postés samedi 9 août 2008Date d'inscription 6 avril 2018 Dernière intervention - 8 mars 2018 à 19:03
Click drt ouvrir dans nouvel onglet et l'image est lisible...
Commenter la réponse de snoop13120