Menu

Creation de module et fichier

bornin90s 37 Messages postés mardi 6 juin 2017Date d'inscription 6 mai 2018 Dernière intervention - 7 mars 2018 à 19:33 - Dernière réponse : Whismeril 11630 Messages postés mardi 11 mars 2003Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention
- 8 mars 2018 à 06:16
Bonjour, est ce que quelqu'un peut me dire si l' algorithme es bon ou pas ? Je suis en train de reviser pour une evaluation. Merci d'avance
L'enoncé de l'exercice
en piéce jointe. Et voici ce que j'ai fait.

type Electeur = structure
DEBUT
numID: chaine
sexe, nom, pnom, add, regiondOrig, regVote: chaine
bVote, nbrePartcip : entier
Fin
const N = 1500
type tab = tableau[1..N]Electeur
var t: tab
type FichierElect = Fichier Electeur
var Felect: FichierElect
Procedure EXO(Donnee t: tab N: entier
Resultat Felect: FichierElect)
var e: Electeur
var i: entier
DEBUT
Ouvrir (Felect)Ecriture
Pour i allant de 1 a N Faire
Si(t[i].bVote = "Dakar ") Alors
t[i] ← e
Ecrire ( e, Felect)
FinSi
FinPour
Fermer(Felect)
FIN
Afficher la suite 

Votre réponse

8 réponses

Whismeril 11630 Messages postés mardi 11 mars 2003Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 7 mars 2018 à 19:51
0
Merci
Bonsoir

je ne sais pas comment c'est au Sénégal, mais en France le numéro de la carte d'électeur est un entier.

Y'a pas de norme pour les algos, mais cette notation m'interpelle

Si(t[i].bVote = "Dakar ") Alors
t[i] ← e
Ecrire ( e, Felect)

Je comprends que le contenu de e est affecté à t[i]

bornin90s 37 Messages postés mardi 6 juin 2017Date d'inscription 6 mai 2018 Dernière intervention - 7 mars 2018 à 20:58
e est une variable de la structure Etudiant. Au lieu d'écrire Etudiant.bVote j'écris tout simplement e.bVote.
Whismeril 11630 Messages postés mardi 11 mars 2003Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 7 mars 2018 à 21:10
je me suis mal exprimé.
Déclarer une variable n'est pas l'initialiser.

Dire que e est un étudiant, ne veux pas dire que e est Albert Dupont.
Dire que e est un étudiant équivaut à dire que e est un étudiant vide.
bornin90s 37 Messages postés mardi 6 juin 2017Date d'inscription 6 mai 2018 Dernière intervention - 7 mars 2018 à 23:18
Oui je me suis trompée je voudrai dire que e ← t[i]
bornin90s 37 Messages postés mardi 6 juin 2017Date d'inscription 6 mai 2018 Dernière intervention - 7 mars 2018 à 23:19
et puis on ecrit e dans le fichier
Whismeril 11630 Messages postés mardi 11 mars 2003Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 8 mars 2018 à 06:16
Ha voilà c’est mieux.
Commenter la réponse de Whismeril