Menu

Plusieurs Conditions

storm3519 4 Messages postés mercredi 7 mars 2018Date d'inscription 8 mars 2018 Dernière intervention - 7 mars 2018 à 13:36 - Dernière réponse : PapyLuc51 1517 Messages postés dimanche 3 mai 2009Date d'inscription 18 juin 2018 Dernière intervention
- 8 mars 2018 à 16:32
Bonjour,

Je cherche à faire la formule suivante sur EXCEL:

J'ai un produit avec une remise de gamme
6% pour 3 gammes
2% pour 2 gammes
et aucune remise si 1 seule gamme

J'ai fais cette formule: =SI(OU(B7;B8;B9>=1);C7*0,94;SI(OU(B7>=1;B8>=1;B9>=0);C7*0,98);SI(OU(B7>=1;B8>=0;B9>=1);C7*0,98;SI(OU(B$>=0;B8>=1;B9>=1);C7*0,98;C7)))

Cela ne fonctionne pas car j'ai trop d'arguments. Je ne comprends pas l'erreur.

Pouvez-vous m'aider ?

Merci d'avance.
Afficher la suite 

Votre réponse

9 réponses

PapyLuc51 1517 Messages postés dimanche 3 mai 2009Date d'inscription 18 juin 2018 Dernière intervention - Modifié par PapyLuc51 le 7/03/2018 à 14:00
0
Merci
Bonjour

les conditions générales OK ; mais il faudrait détailler les particularités de B7, B8, B9 pour déclencher le grammage nécessaire à l'octroi ou non d'une remise
Voir en gras les erreurs dans la formule

=SI(OU(B7=à quoi;B8= à quoi;B9>=1);C7*0,94;SI(OU(B7>=1;B8>=1;B9>=0);C7*0,98)parenthèse en trop;SI(OU(B7>=1;B8>=0;B9>=1);C7*0,98;SI(OU(B$ ça n'est pas une cellule>=0;B8>=1;B9>=1);C7*0,98;C7))))parenthèse manquante

Envoyez une copie du fichier avec les explications nécessaires via cjoint

Cordialement
storm3519 4 Messages postés mercredi 7 mars 2018Date d'inscription 8 mars 2018 Dernière intervention - 8 mars 2018 à 11:18
PapyLuc51 1517 Messages postés dimanche 3 mai 2009Date d'inscription 18 juin 2018 Dernière intervention > storm3519 4 Messages postés mercredi 7 mars 2018Date d'inscription 8 mars 2018 Dernière intervention - 8 mars 2018 à 12:34
Je regarde en détail tout à l'heure mais déjà à première vue il y a des références circulaires.

A plus tard
Cordialement
PapyLuc51 1517 Messages postés dimanche 3 mai 2009Date d'inscription 18 juin 2018 Dernière intervention > storm3519 4 Messages postés mercredi 7 mars 2018Date d'inscription 8 mars 2018 Dernière intervention - 8 mars 2018 à 14:26
je viens de me rendre compte de mon erreur en voyant le tableau ; j'ai confondu gamme et gramme

Donc s'il n'y pas de commande en B7, D7 reste vide ; si les trois produits sont commandés on applique une remise de 6% sur chaque ligne ; si deux produits sont commandés on applique une remise de 2% sur les deux lignes concernées et enfin 1 seul produit commandé le prix ne change pas.
Donc la formule à appliquer est pour D7

=SI(B7<>"";SI(ET($B$7>=1;$B$8>=1;$B$9>=1);C7*0,94;SI(OU(ET($B$7>=1;$B$8>=1;$B$9=0);ET($B$7>=1;$B$8=0;$B$9>=1);ET($B$7=0;$B$8>=1;$B$9>=1));C7*0,98;C7));"")

Par contre il va falloir donner des explications détaillées pour les autres remises je n'ai pas encore saisi la méthode de calcul.

A te lire

Cordialement
storm3519 4 Messages postés mercredi 7 mars 2018Date d'inscription 8 mars 2018 Dernière intervention - 8 mars 2018 à 15:49
Merci beaucoup.

Cordialement
PapyLuc51 1517 Messages postés dimanche 3 mai 2009Date d'inscription 18 juin 2018 Dernière intervention > storm3519 4 Messages postés mercredi 7 mars 2018Date d'inscription 8 mars 2018 Dernière intervention - 8 mars 2018 à 16:32
Je ne comprends toujours pas l'intérêt de calculer les remises de gamme et les remises CA-PRODUIT puisqu'elles ne rentrent pas en compte pour le calcul du TOTAL.

Enfin bref, pour éviter #VALEUR! dans les calculs des colonnes E, F, G il faut changer les formules

en E7
=SIERREUR(SI(G7>=10000;D7*0,94;SI(G7>=5000;D7*0,96;SI(G7>=1000;D7*0,98;D7)));"")

en F7
=SIERREUR(SI($G$14>=120000;E7*0,94;SI($G$14>=90000;E7*0,96;SI($G$14>=70000;E7*0,98;E7)));"")

en G7
=SIERREUR(SOMME(B7*F7);"")

Cordialement
Commenter la réponse de PapyLuc51