Menu

Site fonctionnel MAIS le domaine retourne 404 ! [Résolu]

Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 27 févr. 2018 à 11:47 - Dernière réponse : Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention
- 4 mars 2018 à 01:16
Bonjour tout le monde, merci de jeter un oeil à mon topic !

Voici mon problème: j'ai commencé à créer un site web dont le nom de domaine est : avrilisaway.com.
Le problème c'est que cette adresse retourne systématiquement des erreurs 404, alors que mes autres pages, comme avrilisaway.com/japan, marche parfaitement bien.

Pire, j'ai créer une page d’accueil qui marche très bien toute seule, mais dès que je la sélectionne avec l'option "static page" pour les pages home & blog dans l'onglet Reading des paramètres de wordpress, elle disparaît à son tour et renvoi 404.

Dans l'absolu je pourrais faire une redirection vers un sous-level du site puisqu'ils marchent, mais bon, j'ai réservé un nom de domaine pour une bonne raison, j'aimerais bien pouvoir l'utiliser !
Avez-vous une idée de ce qui pourrait causer ces 404 ? J'ai passé plusieurs heures à naviguer sur internet à la recherche d'une réponse en vain, d'où mon post içi.

Bonne journée et merci d'avance,
Avril
Afficher la suite 

Votre réponse

12 réponses

elgazar 4601 Messages postés mercredi 30 octobre 2013Date d'inscription 15 juin 2018 Dernière intervention - 27 févr. 2018 à 15:55
0
Merci
Bonjour

oui la cause de ces 404, ce sont tes erreurs


Plus sérieusement tu mélanges plusieurs trucs qui ne vont pas ensemble

soit tu crée une page index.html qui te servira de page d'accueil et qui contiendra un lien vers la page index.php qui est la page d'accueil de ton blog (que ce soit une page statique ou la rotation d'articles, c'est toujours index.php)

soit (et c'est la meilleure solution), tu utilises une page statique pour personnaliser la page d'accueil de ton blog et tu vires la page index.html et la redirection que tu as mis quelque part qui renvoie systématiquement la page index.php vers une page html qui n'existe pas

Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 27 févr. 2018 à 16:07
Salut Elgazar,
Je n'en doute pas un seul instant, 99% des problèmes étant situés entre la chaise et le pc.

Je crois pas avoir créer la page index.html moi même par contre. Est-ce possible qu'elle soit partie intégrante de mon thème, Ocean WP ?
Dans l'absolu, comment je fais pour la supprimer, puisqu'elle n'apparait pas en tant que page dans mon tableau de bord wordpress ?

Merci encore pour ton aide !
Commenter la réponse de elgazar
elgazar 4601 Messages postés mercredi 30 octobre 2013Date d'inscription 15 juin 2018 Dernière intervention - 27 févr. 2018 à 21:54
0
Merci
quelque part tu as une redirection qui envoie le visiteur de la page d'accueil de ton blog (index.php) vers une page index.html inexistante d'où l'erreur 404 .
bref c'est une erreur que tu as du faire quelque part soit dans le fichier htaccess soit dans le code de la page ( header.php) soit dans la configuration de wordpress
Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 27 févr. 2018 à 23:13
En effet, je crois que je cerne un peu mieux le problème.
J'ai tenté de tracer les redirections et voilà ce que j'obtiens :

avrilisaway.com

HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Tue, 27 Feb 2018 22:07:46 GMT
Content-Type: text/html; charset=iso-8859-1
Content-Length: 232
Connection: keep-alive
Location: https://avrilisaway.com/
X-Proxy-Cache: MISS

https://avrilisaway.com/

HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Tue, 27 Feb 2018 22:07:47 GMT
Content-Type: text/html; charset=iso-8859-1
Content-Length: 242
Connection: keep-alive
Location: https://avrilisaway.com/index.html
X-Proxy-Cache: MISS

https://avrilisaway.com/index.html

HTTP/1.1 404 Not Found
Server: nginx
Date: Tue, 27 Feb 2018 22:07:48 GMT
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
X-UA-Compatible: IE=edge
Expires: Wed, 11 Jan 1984 05:00:00 GMT
Cache-Control: no-cache, must-revalidate, max-age=0
Link: ; rel="https://api.w.org/"
Host-Header: 192fc2e7e50945beb8231a492d6a8024

Je me demande si tout cela n'est pas un vestige de mon changement de domaine de aprilisaway à avrilisaway. Une idée de marche à suivre pour régler tout ça ? Ou du moins un endroit où chercher ?
Je suis hébergé par Siteground, et j'ai trouvé mon htaccess, je dois pouvoir l'uploader si ca peux aider.
Je continue à chercher de mon côté.

Merci encore pour ton aide.
Commenter la réponse de elgazar
elgazar 4601 Messages postés mercredi 30 octobre 2013Date d'inscription 15 juin 2018 Dernière intervention - 28 févr. 2018 à 09:15
0
Merci
c'est quelque chose que tu as modifié donc tu dois savoir mieux que moi si tu as changé le fichier htaccess
Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 28 févr. 2018 à 12:48
Je pense pas l'avoir modifié puisque j'ai découvert comment le trouver qu'hier :/
Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 28 févr. 2018 à 13:02
Du coup, est-ce que tu saurais me dire comment est ce que je le modifie pour enlever ces redirections s'il te plait ?
Commenter la réponse de elgazar
elgazar 4601 Messages postés mercredi 30 octobre 2013Date d'inscription 15 juin 2018 Dernière intervention - 28 févr. 2018 à 17:54
0
Merci
Pour le fichier htaccess, il suffit de chercher si il contient une ligne avec index.html dedans, si c'est le cas c'est la redirection puisque wordpress n'utilise que des fichiers php,

dans ton premier message, tu indiques
' mais dès que je la sélectionne avec l'option "static page" pour les pages home & blog dans l'onglet Reading des paramètres de wordpress, elle disparaît à son tour et renvoi 404. ', tu parles de quelle page exactement d'une page de wordpress ou d'une page html ?
Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 1 mars 2018 à 20:35
Ok, je viens enfin de trouver le htaccess, et il contient effectivement des lignes concernant le fameux index.html ! Est-ce que tu saurais comment je supprime ces redirections sans tout casser ?

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

#Weebly Additions Start
ErrorDocument 404 /w_api/Handler.php

RewriteEngine on

RewriteCond %{HTTP_HOST} !^avrilisaway.com [NC]
RewriteCond %{HTTP_HOST} !^$
RewriteCond %{HTTPS}:s (on:(s)|off:s)
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^/?(.*) http%2://avrilisaway\.com/$1 [L,R=301,NE]

Options
RewriteEngine on

RewriteCond %{REQUEST_URI} !-f
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^ajax/(.*)$ /w_api/Handler.php [L]

RewriteBase /
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^$ index.html [R=301,L]

RewriteCond %{REQUEST_URI} !-f
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^index.html(.*)$ /w_api/Handler.php [QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^(.*)$ /w_api/Handler.php

#Weebly Additions End
RewriteCond %{HTTP_HOST} ^aprilisaway\.com$ [OR]
RewriteCond %{HTTP_HOST} ^www\.aprilisaway\.com$
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^/?$ "http\:\/\/avrilisaway\.com" [R=301,L]
Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 1 mars 2018 à 20:57
Bon, je savais que j'aurais du patienter, mais j'ai tenté de supprimer les additions de Weebly (que j'avais testé sur mon site avant de changer de domaine) en pensant que c'était peut-être le problème, mais même après avoir restauré le fichier d'origine, tout mon signe renvoie une erreur 500 maintenant ...
Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 1 mars 2018 à 20:59
J'ai rien dit, il manquait juste le "." du .htaccess dans ma version réuploadé
Spaydh 13 Messages postés samedi 13 août 2011Date d'inscription 4 mars 2018 Dernière intervention - 4 mars 2018 à 01:16
J'ai finit par réinstaller le site après avoir sauvegarder mes templates de page et le nouveau .htaccess fonctionne
Commenter la réponse de elgazar