Menu

2ème authentification avec htaccess et htpasswd

manchelo 315 Messages postés jeudi 29 janvier 2009Date d'inscription 15 mai 2018 Dernière intervention - 26 févr. 2018 à 18:43 - Dernière réponse : manchelo 315 Messages postés jeudi 29 janvier 2009Date d'inscription 15 mai 2018 Dernière intervention
- 4 mars 2018 à 20:22
Bonjour,

voici depuis un moment que j'essaie d'ajouter une 2ème authentification pour accéder à mon admin Wordpress. Mais sans succès.

Pour se faire, j'utilise un fichier .htaccess que je place dans le dossier wp-admin. J'y note ceci :
AuthUserFile /home/monnomFTP/www/.htpasswd
AuthGroupFile /dev/null
AuthName "Accès Restreint"
AuthType Basic
require valid-user

lié à ce fichier, j'ajoute dans le dossier source du site (dans mon cas : www) un fichier nommé .htpasswd. J'y note ceci :
MonNomDeLogin:MonMotDePasseCryptéSurOVH


Lorsque je souhaite me connecter à mon administration Wordpress, une authentification est requise avant d'afficher la principale.
Mais lorsque je tape les identifiants de mon fichier .htpasswd, le panneau d'authentification disparait et réapparait aussitôt et rafraichi.

J'ai testé 4 tutos différents. Le contenu du fichier .htaccess est un peu différent de l'un à l'autre. Mais je reste confronté au même problème.


Ce n'est pas évident à expliquer alors j'espère que vous parviendrez à comprendre ce qui dysfonctionne :)
Avez-vous une idée d'où provient le problème ?

Merci d'avance
À vous lire
Afficher la suite 

Votre réponse

6 réponses

Judge_DT 22275 Messages postés vendredi 5 février 2010Date d'inscriptionModérateurStatut 16 juin 2018 Dernière intervention - 26 févr. 2018 à 23:19
0
Merci
Salut,

Viré la ligne sur l'authgroupfile.

Quel est le serveur web qui héberge ton wordpress ? Apache ? Quelle version ?

En principe sans cette ligne ça devrait fonctionner sans problème particulier.
manchelo 315 Messages postés jeudi 29 janvier 2009Date d'inscription 15 mai 2018 Dernière intervention - 27 févr. 2018 à 08:40
Bonjour et merci pour cette première réponse,

Alors j'ai supprimé AuthGroupFile /dev/null
Cela ne change pas le problème.

C'est OVH qui héberge directement mon site en multisite.

J'ai 2 fichiers htaccess. L'un à la source (www), l'autre dans le dossier wp-admin. Est ce qu'ils peuvent rentrer en conflit ? Bien qu'il est normalement possible de mettre un fichier de ce type dans tous les dossiers que l'on souhaite protéger...


Merci d'avance :)
manchelo 315 Messages postés jeudi 29 janvier 2009Date d'inscription 15 mai 2018 Dernière intervention - 27 févr. 2018 à 12:08
J'ai remarqué qu'en ajoutant des guillemets à htpasswd sur le chemin d'accès AuthUserFile,
à savoir : /home/monnomFTP/www/“.htpasswd“

la fenêtre d'authentification fonctionne bien.
Elle pop, j'écris mes identifiants, je fais OK et elle ne pop plus. Alléluia :)


Mais maintenant le problème survient lors de la 2ème authentification (Celle de worpdress de base).
En effet, une fois les identifiants tapés, cela m'indique Internal Server Error.

Pffff ! Ça m’énerve !
manchelo 315 Messages postés jeudi 29 janvier 2009Date d'inscription 15 mai 2018 Dernière intervention - 1 mars 2018 à 17:16
Comment vérifier que je n'utilise pas Apache ? J'ai un énorme doute maintenant...
Commenter la réponse de Judge_DT
manchelo 315 Messages postés jeudi 29 janvier 2009Date d'inscription 15 mai 2018 Dernière intervention - 28 févr. 2018 à 12:27
0
Merci
En continuant de fouiller, je suis tombé sur certains tutos qui indiquent que les requêtes Ajax ne fonctionneront plus car le fichier htaccess bloque l'intégralité du dossier wp-admin.

J'ai testé en tapant ces lignes dans mon htaccess :

# Requête Ajax
AuthType Basic
AuthName "Protected page"
AuthUserFile "/home/monnomFTP/www/.htpasswd"

Require valid-user
<Files admin-ajax.php>
Order allow,deny
Allow from all
Satisfy any
</Files>
<Files admin-post.php>
Order allow,deny
Allow from all
Satisfy any
</Files>
<Files "\.(css|gif|png|js)$">
Order allow,deny
Allow from all
Satisfy any
</Files>

# Seconde Authentification
<Files admin-ajax.php>
Order allow,deny
Allow from all
Satisfy any
</Files>

AuthName "Connexion à l'administration"
AuthType Basic
AuthUserFile "/home/monnomFTP/www/.htpasswd"

Require valid-user



Mais le résultat est encore et toujours le même.
Je rentre mes bons identifiants cryptés. Ça charge une micro seconde et ça me redemande mes identifiants.

Au vu des innombrables sujets identiques postés sur internet, je pensais finir par trouver la solution. Y a t il un espoir ? :(
manchelo 315 Messages postés jeudi 29 janvier 2009Date d'inscription 15 mai 2018 Dernière intervention - 4 mars 2018 à 20:22
Toujours pas d'idée ?

mon code htaccess actuel :
AuthName "Connexion a l'administration"
AuthType Basic
AuthUserFile "home/monnomftp/www/.htpasswd"
Require valid-user


lors de l'authentification pour accéder à la page admin, les identifiants htpasswd sont bons et me permettre d'y accéder.
Mais lorsque je tape mes identifiants wordpress de la page admin pour accéder à mon site, j'ai l'erreur 500 Internal Server Error suivi de :
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at postmaster@www.monsite.com to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.


Il y a des tas de posts identiques à celui ci sur internet mais je ne trouve pas de solution pour mon problème.


Autre question : Mon serveur web qui héberge mon site est normalement OVH (compris dans l'offre gold). Mais j'ai un doute quant au lien avec Apache cité par Judge_DT.
Est ce bien la même chose ?

Mon problème vient il d'Ajax ?
Je bloque depuis 1 semaine sur ce problème. C'est un calvaire !


Merci d'avance pour toutes réponses apportées
Commenter la réponse de manchelo