Menu

Installation d'asterisk sur ubuntu 12.04

halelujah - 22 févr. 2018 à 20:50 - Dernière réponse : mamiemando 28419 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 22 juin 2018 Dernière intervention
- 28 févr. 2018 à 10:28
Bonjour,

J'essaie installer Asterisk sur linux ubuntu 12.04, mais j'ai toujours le même problème. S'il vous plait aidez-moi le plus tôt possible .

Merci d'avance cher(e)s ami(e)s

/home/ctadmin# sudo apt-get install build-essential libxml2-dev libncurses5-dev linux-headers-`uname -r` libsqlite3-dev libssl-dev

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet linux-headers-3.13.0-98-generic n'est disponible, mais il existe dans la base de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète ou qu'il n'est disponible que sur une autre source

E: Le paquet « linux-headers-3.13.0-98-generic » n'a pas de version susceptible d'être installée
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
mamiemando 28419 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 22 juin 2018 Dernière intervention - Modifié par mamiemando le 28/02/2018 à 10:30
1
Merci
Bonjour,

Si un paquet n'est plus disponible, cela signifie que tu dois au moins :
  • réindexer les nouvelles versions de paquets et les nouvelles dépendances (
    sudo apt-get update
    )
  • de préférence faire une mise à jour (
    sudo apt-get upgrade
    )
  • puis installer ton paquet.


Concernant l'installation elle-même, je ne pas trop comprendre pourquoi dans la documentation ubuntu, il choisissent de compiler asterisk pour l'installer. Il serait bien plus propre et plus simple de l'installer avec
sudo apt-get install asterisk
, car asterisk est disponible dans les paquets proposés par ubuntu.

Malheureusement, quelle que soit l'approche retenue, tu risques d'être bloquée car ta distribution n'est plus maintenue. En effet ubuntu 12.04 date (comme son nom l'indique) d'avril 2012, et ça fait longtemps qu'elle n'est plus maintenue.

Du coup, il est donc très probable que les commandes
apt-get
sus-mentionnée ne fassent rien et ne te débloquent pas. Si c'est le cas, il faut :

Ensuite reprends la démarche indiquée au début de mon message.

Bonne chance

Merci mamiemando 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24235 internautes ce mois-ci

Commenter la réponse de mamiemando