Menu

Formule SI avec Maximum à 3 conditions [Résolu]

Suki_BT - 13 févr. 2018 à 10:03 - Dernière réponse : Vaucluse 21989 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 mai 2018 Dernière intervention
- 15 févr. 2018 à 12:47
Bonjour,

Je dois mettre en place un "plafond de montant" sur un imprimé de remboursement soumis à conditions. La personne sélectionne la zone dans un menu déroulant (Zone 1, Zone 2 et Zone 3). Si la personne sélectionne Zone 1 le montant maxi est de 112.16€, si zone 2 le maxi est 101.97€ et si zone 3 le maxi est 86.67€
Comment mettre la formule en place si en rentrant un montant la personne écrase la formule qui est dans la cellule ?

Merci de votre aide :)
Afficher la suite 

Votre réponse

4 réponses

Vaucluse 21989 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 mai 2018 Dernière intervention - 13 févr. 2018 à 10:29
0
Utile
Bonjour
l'ancien fichier est peut être quelque part, mais il manque le lien pour le retrouver!
ceci dit, avec la sélection de la zone en A1, pour avoir le maxi en B1:

=SI(A1="Zone 1";112,16;SI(A1="Zone 2";101,97;SI(A1="Zone 3";86,67;"")))

et pour ne pas écraser la formule il faut par exemple prévoir la colonne B utile en B et l'entrée de la valeur en C avec cette formule en B:
=MIN(SI(A1="Zone 1";112,16;SI(A1="Zone 2";101,97;SI(A1="Zone 3";86,67;0)));C1)
qui ne dépassera pas là valeur trouvée par la formule


sinon vous avez la possibilité d'interdire par validation d'entrer une valeur > que le maxi*
voyez ici:
https://mon-partage.fr/f/OWlipQlj/

colonne A zones
colonne B et C 1° sol
colonne E 2° soll
(dans celle ci voir onglet / données/ Validation)

revenez si besoin

crdlmnt






Suki_BT 9 Messages postés jeudi 28 avril 2016Date d'inscription 15 février 2018 Dernière intervention - 13 févr. 2018 à 11:20
Merci bcp :) J'ai essayé de joindre le fichier mais je n'ai pas réussi, cela fait un moment que je ne suis pas venue dans le forum. Je vais essayer de refaire selon vos indications, merci encore et bonne journée.
Suki_BT 9 Messages postés jeudi 28 avril 2016Date d'inscription 15 février 2018 Dernière intervention - 15 févr. 2018 à 12:44
Merci bcp @Vaucluse, c'est parfait. J'essayais avec la fonction Max pas étonnant que j'y arrivais pas. vous m'avez sauvée. Bonne journée, Suki
Vaucluse 21989 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 mai 2018 Dernière intervention - 15 févr. 2018 à 12:47
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse