Menu

Tableau excel calcul nb de jours ouvrés nombre nég [Résolu]

Mathildeeeeeeee 5 Messages postés vendredi 9 février 2018Date d'inscription 10 février 2018 Dernière intervention - 9 févr. 2018 à 16:16 - Dernière réponse : Mathildeeeeeeee 5 Messages postés vendredi 9 février 2018Date d'inscription 10 février 2018 Dernière intervention
- 10 févr. 2018 à 09:26
Bonjour, après avoir fouillé dans les forums et les support office je ne trouve pas réponse à ma question. J'ai un tableau sur lequel je dois calculé le nombre de jours ouvrés depuis le dépôt d'un document, jusqu'à son retour. Si je n'ai pas encore la date de retour cela m'affiche un nombre négatif. De plus avec ma formule =SI(OU(D3="";AUJOURDHUI()="");"";NB.JOURS.OUVRES(D3;H3))
j'ai un jour en trop. Exemple dépôt le 01/02, retour le 07/02 et j'ai une durée de traitement de 5 jours alors qu'en réalité cela fais 4 jours ouvrés.
Je souhaiterais également pouvoir faire une mise en forme conditionnelle pour mettre en rouge si délai supérieur à 8 jours mais quand je le fais et que j'étale ma formule les champs vide apparaissent rouge.

1ère question : Pourquoi ai-je un jour en plus dans ma formule ?
2ème question : Comment faire pour ne plus avoir de nombres négatifs si je n'ai pas encore la date de retour (puis-je avoir le nombre de jour qui s'écoule au fur et à mesure?)
3ème question : J'ai les mêmes formules sur les deux colonnes de droite et pourtant sur la dernière je n'ai rien du tout alors que j'ai également mis une date de dépôt ?
4ème quesiton : Comment faire pour la mise en forme conditionnelle sans que tout soit en rouge ?

Je suis complètement perdue, et je n'aurais bientôt plus de cheveux à m'arracher.. Merci d'avance, vous verrez une photo de mon tableau j'espère que ça pourra vous aider à comprendre..




Afficher la suite 

8 réponses

Répondre au sujet
Mathildeeeeeeee 5 Messages postés vendredi 9 février 2018Date d'inscription 10 février 2018 Dernière intervention - 9 févr. 2018 à 16:30
+1
Utile
5
Bon alors je viens de m'apercevoir d'une erreur, j'ai mis la colonne H et non D dans le début de ma formule et les nombres négatifs ont disparu. Par contre pour les autres questions je n'y arrive toujours pas..
Cette réponse vous a-t-elle aidé ?  
Patrice33740 6803 Messages postés dimanche 13 juin 2010Date d'inscription 28 avril 2018 Dernière intervention - 9 févr. 2018 à 16:46
Un jour en plus ?
Non, sont ouvrés les 1, 2, 5, 6 et 7/02/2018 soit 5 jours (du 01/02 au 01/02 il y a un jour ouvré).
Mathildeeeeeeee 5 Messages postés vendredi 9 février 2018Date d'inscription 10 février 2018 Dernière intervention - 9 févr. 2018 à 17:01
Je comprend mais comment puis-je faire dans ce cas ? Car on est d'accord que si je dépose un document le 01/02 et que j'ai un retour le 07/02 dans la logique le dossier a mis 4 jours a être traité
eriiic 21547 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 29 avril 2018 Dernière intervention - 9 févr. 2018 à 17:26
Bonjour,

si tu ne veux pas compter le dernier jour et bien tu fais -1
eric
Patrice33740 6803 Messages postés dimanche 13 juin 2010Date d'inscription 28 avril 2018 Dernière intervention - 9 févr. 2018 à 18:59
« Car on est d'accord que si je dépose un document le 01/02 et que j'ai un retour le 07/02 dans la logique le dossier a mis 4 jours a être trait»
Pas forcement, si tu le dépose le 01/02 à l'embauche et que tu le récupère le 07/02 à la débauche, il y a bien 5 jours ouvrés!
Sur le principe que toute journée commencée est due.
Mathildeeeeeeee 5 Messages postés vendredi 9 février 2018Date d'inscription 10 février 2018 Dernière intervention - 10 févr. 2018 à 09:26
Oui c'est vrai, merci à tous !
Commenter la réponse de Mathildeeeeeeee
Vaucluse 21909 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 30 avril 2018 Dernière intervention - Modifié par Vaucluse le 9/02/2018 à 17:25
0
Utile
1
Bonjour

A) dans votre formule écrire en condition AUJOURDHUI()="" est inutile puisque AUJOURDHUI() renvoie toujours la date du jour en cours et jamais rien!

B) si vous ne voulez pas inclure les limites dans le délai, il suffit de compléter la formule par -1, )c'est comme pour les intervalles) soit:
pour éviter que la formule renvoie une bêtise si une des dates est absente
=SI(OU(D3="";H3="");"";NB.JOURS.OUVRES(D3;H3)-1)

C) délai de modif: il n'y a que la ligne 20 qui peut renvoyer un résultat, c'est la seule dans l'image à afficher des dates de modif

E) vous ne dites pas ce que vous voulez passer en rouge, mais si c'est pour mettre la date en F en rouge si elle est dépassée alors qu'il n'y a pas de date en H MFC par formule, la formule est:

=ET($F3<>"";$H3="";$F3<AUJOURDHUI())

donc, précisez bien F3<>"" pour éviter l'affichage des vides en rouge puisque F vide est <AUJOURDHUI()

F) pour info en complément avec la formule NB.JOURS.OUVRES, vous pouvez aussi éliminer les jours fériés
par exemple si vous faite une liste de jours à exclure en Z1:Z20

=NB.JOURS.OUVRES(D3;H3;$Z$1:$Z$20) éliminera les dates de Z1 à Z20 (et une seule fois s'il s'agit de dimanche ou samedi)

revenez si ça ne convient pas

crdlmnt





Mathildeeeeeeee 5 Messages postés vendredi 9 février 2018Date d'inscription 10 février 2018 Dernière intervention - 10 févr. 2018 à 09:25
Merci beaucoup !
Commenter la réponse de Vaucluse