Menu

Problème formule SI

Luxcel - 9 févr. 2018 à 10:13 - Dernière réponse :  Luxcel
- 9 févr. 2018 à 16:17
Bonjour,

Je bloque sur une bête formule SI -_-
J'ai un tableau tout simple, en gros je faire un suivi de stock. De base j'ai cette formule (avec C comme résultat J-1; A comme stock entrant et B comme stock sortant) : =SI(A5=0;"";SI(B5=0;"";SI(C4="";(C3+A5)-B5;(C4+A5)-B5)))
Mon problème majeur est que parfois il peut y avoir 2 jours de sautés. Donc il faudrait que j'insère dans la formule quelque chose du type SI(C4 et C3="";(C2+A5)-B5)) sauf que bien entendu cela ne fonctionne pas.
Auriez-vous une solution pour me sauver de cette impasse svp ??

Merci d'avance !
Cordialement
Afficher la suite 

Votre réponse

6 réponses

PapyLuc51 1469 Messages postés dimanche 3 mai 2009Date d'inscription 25 mai 2018 Dernière intervention - 9 févr. 2018 à 10:50
0
Merci
Bonjour

Et si tu nous envoyais un copie de ton tableau via cjoint en suivant ces explications avec toutes les explications nécessaires ; personnellement je ne comprends pas cet entre-croisement de lignes.

Cordialement
En gros le tableau donne ça. J'avais l'impression d'être limpide sur la description mais apparemment non xD
Je n'arrive pas à m'exprimer sur le vrai problème.. En fait, s'il y a un week-end de 3 jours ou un jour férié, il ne me faut aucun résultat dans la colonne "nouveau solde". Donc il faut que je vérifie dans les cases au dessus si oui ou non il y a un résultat pour que je le prenne en compte dans le nouveau solde.. Je ne sais pas si c'est plus net ou pas comme explication..

Mois Date Palettes chargées Palettes rendues Nouveau solde
Janvier 01/01/18
02/01/18
03/01/18
04/01/18
05/01/18
06/01/18
07/01/18
08/01/18
09/01/18
10/01/18
11/01/18
12/01/18
13/01/18
14/01/18
15/01/18
16/01/18
17/01/18
18/01/18
19/01/18
20/01/18
21/01/18
22/01/18
23/01/18
24/01/18
25/01/18
26/01/18
27/01/18
28/01/18
29/01/18
30/01/18
31/01/18
Total 0 0 0
PapyLuc51 1469 Messages postés dimanche 3 mai 2009Date d'inscription 25 mai 2018 Dernière intervention > Luxcel - 9 févr. 2018 à 12:30
Je comprend mieux cette fois et il semble que PHILOU10120 (que je salue au passage) t'a donné de bons indices pour ton problème

Cordialement
Commenter la réponse de PapyLuc51
PHILOU10120 4974 Messages postés lundi 16 avril 2012Date d'inscription 25 mai 2018 Dernière intervention - 9 févr. 2018 à 10:52
0
Merci
Bonjour Luxcel

En colonne C mettre cette formule en ligne 1 et la tirer vers le bas

=SOMME(A$1:$A1)-SOMME(B$1:$B1)

Pour le suivi d'un seul stock

Il n'y a pas assez d'info pour comprendre si vous gérez plusieurs référence vous n'en parlez pas?
Commenter la réponse de PHILOU10120
PHILOU10120 4974 Messages postés lundi 16 avril 2012Date d'inscription 25 mai 2018 Dernière intervention - 9 févr. 2018 à 12:22
0
Merci
Bonjour Luxcel

Une idée voir le fichier

https://www.cjoint.com/c/HBjlvQ6MAUx
Merci beaucoup de votre aide !!!! :D Je n'aurai jamais trouvé toute seule
Merci également à PapyLuc51 !

Cordialement
Commenter la réponse de PHILOU10120