Trouver une formule pour gérer un graphique excel [Résolu/Fermé]

Messages postés
133
Date d'inscription
jeudi 19 mars 2009
Statut
Membre
Dernière intervention
14 octobre 2019
- - Dernière réponse : tontong
Messages postés
2282
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
9 octobre 2019
- 13 févr. 2018 à 14:42
Bonjour,

J'ai un tableau dont les données ont été extraites d'un logiciel interne.

Je dois réaliser un graphique général annuel (onglet Woksheet + graphique général). Pour ce tableau là je n'ai pas de souci.

En revanche, je dois également faire un graphique mois / mois avec, d'un mois sur l'autre, le cumul (onglet de juin => Juin seul (car c'est le 1er mois), onglet de juillet => juin + juillet et ainsi de suite).

Or, je voudrais éviter de devoir utiliser un tableau croisé dynamique car avec ce système, si en juin je n'ai pas de machines OBSOLETES (par ex.) la colonne ''obsolète'' disparaît).

C'est pourquoi, sur l'onglet ''graphique JUIN'', je voudrais trouver une formule qui va aller me chercher les données dans l'onglet JUIN qui dit :

En C5, je veux calculer le nombre de machines avec un état ''BON''
En D5, je veux calculer le nombre de machines avec un état ''MAUVAIS''
En E5, je veux calculer le nombre de machines avec un état ''MOYEN''
En F5, je veux calculer le nombre de machines avec un état ''OBSOLETE''

Le tout en fonction de la colonne ''O'' sur l'onglet de JUIN (en sachant que cette colonne peut se prolonger à l'infini).

Et pour finir, le graphique doit se mettre à jour automatiquement mois / mois, avec l'ajout des données supplémentaires d'un mois sur l'autre.

Je ne sais pas si j'ai été assez claire, mais je galère pour trouver les formules et mettre mes graphiques à jour (oui je sais je suis harchis nulle).

Merci à celui ou celle qui saura m'optimiser ce tableau : https://www.cjoint.com/c/HBijTsQAhHS

Bon courage et bonne journée.
Afficher la suite 

4 réponses

Messages postés
50084
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2019
10957
0
Merci
Bonjour Sév.

J'ai passé un bon moment sur ton fichier, mais je suis contraint d'abandonner. En effet :
- Tes tableaux mensuels n'ont pas le même nombre de lignes (de 9 en août jusqu'à 130 en septembre et même 292 dans la première feuille) alors que le total à réaliser est immuablement de 96 !
- Je n'ose pas lancer un tri ou un filtre, puisque les colonnes A à F se sont pas sélectionnées dans la plage à trier ...
- Il y a des doublons inexplicables ; ainsi les lignes 116 & 117, en septembre, indiquent 2 réponses à 2 minutes d'intervalle pour la même armoire F3A32.10 ... il y a 17 autres doublons ce mois-là. Je présume que cela doit fausser les statistiques !
- Il n'y a pas correspondance entre les chiffres de juin quand on passe d'une feuille à l'autre, et je ne comprends pas pourquoi.

Cependant, pour ne pas être complètement négatif, je t'indique que la formule à placer en C5:F5 est
=NB.SI(JUIN!O:O;4:4)
Merci pour te temps passé sur ce fichu tableau. Je vais essayer de me débrouiller autrement.
Bonne soirée.
0
Merci
Bonjour,

Je reviens vers pour savoir si quelqu'un m'aurait trouver la solution ?

De plus, la formule de Raymond => =NB.SI(JUIN!O:O;4:4) ne fonction pas correctement, à savoir que pour les C à F, j'ai besoin d'une formule qui me dit :

- si dans l'onglet du mois de Juin, dans la colonne O, il est écrit ''BON'' alors je compte 1 dans la cellule C5 de mon onglet GRAPHIQUE JUIN, autant de fois que cela sera écrit, si il est écrit ''MAUVAIS'' alors je compte 1 dans la cellule D5 de mon onglet GRAPHIQUE JUIN, autant de fois que cela sera écrit et ainsi de suite pour E5 (MOYEN)et F5 (OBSOLETE);

Dans la formule de Raymond, je ne comprends pas où il va chercher les données.

Mon tableau est disponible ici : https://www.cjoint.com/c/HBijTsQAhHS

Merci de votre aide.

Séverine.
Raymond PENTIER
Messages postés
50084
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 octobre 2019
10957 -
"Dans la formule de Raymond, je ne comprends pas où il va chercher les données".
Je vais les chercher dans la feuille JUIN, colonne O:O
et leur contenu doit être celui de la ligne 4:4

C'est ce que veut dire la formule, et c'est ce que tu as demandé ...
Merci Raymond mais votre formule ne me convenait pas pour le résultat recherché.
Bonne journée.
Messages postés
9168
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
20 octobre 2019
1651
0
Merci
Bonjour

En C5 de la feuille Graphique JUIN
=NB.SI(JUIN!$O:$O;'Graphique JUIN'!C4)

à tirer vers la droite jusqu'en F5

Cdlmnt
Bonjour ccm81,

Voilà une formule qui fonctionne.

Merci beaucoup.

Bonne journée.
Messages postés
2282
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
9 octobre 2019
752
0
Merci
Bonjour,
On peut même aller un peu plus loin:
Essayer:
En C5 de l'onglet Graphique Juillet entrer la formule=NB.SI(INDIRECT($A5&"!$O$2:$O$300");C$4) valider et recopier jusqu'en F6.