Menu

Fonction SI avec des dates [Résolu]

Beta - 31 janv. 2018 à 12:04 - Dernière réponse :  Beta
- 31 janv. 2018 à 12:28
Bonjour chers experts,

Je travaille sur un tableau Excel relativement simple :
colonne A = date de mise en service
colonne B = date du dernier remplacement
colonne C = date à laquelle devra (ou aurait dû) être fait le prochain remplacement
Chaque ligne = 1 client différent

=> prochain remplacement = 10 ans après la date dont il faut tenir compte (donc +120 mois)
La date dont il faut tenir compte = le dernier remplacement ou - à défaut - la mise en service.

Ma formule ci-dessosu ne fonctionne pas .......
=MOIS.DECALER(SI((LC(-1))=″″;(LC(-2));(LC(-1)));120)

Vous savez me dire pourquoi ? :-(

Merci d'avance !
Un utilisateur un peu perdu ...
Afficher la suite 

Votre réponse

3 réponses

Patrice33740 6834 Messages postés dimanche 13 juin 2010Date d'inscription 20 mai 2018 Dernière intervention - 31 janv. 2018 à 12:25
+1
Utile
Bonjour,

Parce tu utilises le caractère spécial ″ au lieu du caractère normal " (code 34) :
=MOIS.DECALER(SI((LC(-1))="";(LC(-2));(LC(-1)));120)
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de Patrice33740
PapyLuc51 1462 Messages postés dimanche 3 mai 2009Date d'inscription 20 mai 2018 Dernière intervention - 31 janv. 2018 à 12:21
0
Utile
Bonjour,

Voir si cette formule convient : en considérant A2 B2 C2

=SI(B2<>"";MOIS.DECALER(B2;120);MOIS.DECALER(A2;120))

Cordialement
Commenter la réponse de PapyLuc51
0
Utile
Impeccable !!! Merci pour votre rapidité à tous les deux !
Commenter la réponse de Beta