Menu

Définir des valeurs à une cellule [Résolu/Fermé]

Messages postés
967
Date d'inscription
mercredi 25 mars 2015
Statut
Membre
Dernière intervention
2 janvier 2019
- - Dernière réponse : pbertout
Messages postés
967
Date d'inscription
mercredi 25 mars 2015
Statut
Membre
Dernière intervention
2 janvier 2019
- 28 janv. 2018 à 21:58
Bonjour,

Je cherche depuis un moment une solution à mon problème mais je ne trouve pas...

Voila j'ai un tableau avec des produits en commande.
J'ai une colonne, quantité et à côté une autre colonne prix, je souhaiterais que la cellule prix change lorsque l'on modifie le nombre dans quantité.

Exemple :

quantité 0 prix 0
quantité 1 prix 52
quantité 2 prix 104

Ce ne doit pas être compliqué mais j'utilise très peu Excel donc pas facile..

Merci par avance.
Afficher la suite 

2 réponses

Messages postés
1663
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
4 mai 2019
291
0
Merci
Salut,

La base de la base d'Excel : en A1, tu mets la quantité, en A2, le prix à l'unité et en A3 le calcul c'est à dire
=A1*A2

Si le prix à l'unité varie en fonction de la quantité, dans ce cas, soit tu as une règle mathématique, soit tu passe par la fonction SI ou SI MULTIPLE

pbertout
Messages postés
967
Date d'inscription
mercredi 25 mars 2015
Statut
Membre
Dernière intervention
2 janvier 2019
65 -
Bonjour,

Merci pour l'info, la formule m'aidera partiellement. Je vais compléter la suite du tableau avec la réponse de Mike-31.

Bien cordialement.
Messages postés
16904
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 juin 2019
3489
0
Merci
Bonsoir,

si ta première quantité est en A2 en B2 colle cette formule
=52*A2
ou
=SI(A2>0;52*A2;0)

ensuite incrémente la formule vers le bas
mais le prix unitaire 52 est certainement dans une cellule exemple en F1
la formule devient
=SI(A2>0;F1*A2;0)
il est possible de compléter la formule pour éviter l'affichage 0 lorsque les cellules colonne A sont vides
=SI(A2<>"";52*A2;"")
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
pbertout
Messages postés
967
Date d'inscription
mercredi 25 mars 2015
Statut
Membre
Dernière intervention
2 janvier 2019
65 -
Bonjour,

Merci pour l'aide, j'ai pu finir le tableau comme je le souhaitais.

Bien cordialement.