Menu

Concatener une plage de cellule variable [Résolu]

texastina 46 Messages postés jeudi 15 janvier 2015Date d'inscription 30 janvier 2018 Dernière intervention - 25 janv. 2018 à 17:38 - Dernière réponse : texastina 46 Messages postés jeudi 15 janvier 2015Date d'inscription 30 janvier 2018 Dernière intervention
- 30 janv. 2018 à 11:28
Bonjour à tous,

Merci d'avance pour votre aide!

Vous trouverez ci-dessous le lien de mon tableau Excel,

Mon problème est le suivant : je souhaiterais comme sur la photo que tous les nombres (en colonne B) correspondant au produit A soient Concatener en colonne F, idem pour les nombre des produits B et C.

J'ai volontairement simplifié mon tableau afin "d'y voir plus clair" mais en réalité mon tableau a un nombre de ligne variable et un produit A ou B ou C... n'a pas forcément plusieurs nombres. Je cherche donc un moyen VBA ou formule me permettant d'automatiser ce traitement de données.

https://www.cjoint.com/c/HAzqLy2V4Nx


Merci beaucoup pour vos aides!
Afficher la suite 

Votre réponse

2 réponses

PHILOU10120 4972 Messages postés lundi 16 avril 2012Date d'inscription 21 mai 2018 Dernière intervention - 25 janv. 2018 à 18:47
+1
Utile
Bonjour Texastina

Essayer ceci si j'ai bien compris votre problème

=CHOISIR(SI(A2="A";1;SI(A2="b";2;SI(A2="c";3;SI(A2="d";4;SI(A2="e";5;6)))));$B$2&$B$3&$B$4&$B$5&$B$6&$B$7;$B$8&$B$9&$B$10&$B$11&$B$12&$B$13;$B$14&$B$15&$B$16;$B$17;$B$18&$B$19;$B$20&$B$21&$B$22&$B$23)
Cette réponse vous a-t-elle aidé ?  
texastina 46 Messages postés jeudi 15 janvier 2015Date d'inscription 30 janvier 2018 Dernière intervention - 30 janv. 2018 à 11:28
Bonjour Philou10120,

Merci pour votre réponse, elle fonctionne très bien,
En revanche étant donné que le nombre de ligne reste conséquent j'avais besoin d'une formule qui puisse se tirer et s'actualiser, j'ai donc jouer avec les fonctions SI et trouver ma solution,

Mes formules : En C2 =SI(A2=A3;B2&" "&C3;B2) En D2 =SI(A2<>A1;C2;"")

Merci encore bonne journée,
Commenter la réponse de PHILOU10120