Comparer deux fichiers excel [Fermé]

Messages postés
2
Date d'inscription
jeudi 25 janvier 2018
Statut
Membre
Dernière intervention
25 janvier 2018
- - Dernière réponse : PHILOU10120
Messages postés
5375
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
5 décembre 2019
- 25 janv. 2018 à 14:25
Bonjour,

Je cherche a comparer deux fichiers excel.

Ils ont tous les deux les mêmes colonnes, dans le même ordre.
Par contre pas les mêmes lignes.

Je m'explique :
> J'ai une base de 1 000 personnes qui comprend une cinquantaines de colonnes, dont un identifiant unique, leur adresse,n° tel etc...
> Je souhaite pouvoir comparer cette base, avec la même base mais datée de l'année dernière

L'objectif est de mettre en lumière les modifications (quelqu'un qui aurait changé d'adresse par ex)

J'ai tenté avec Spreadsheet Compare mais le problème que j'ai c'est que dans mon fichier le plus récent, j'ai des nouvelles lignes.
J'ai aussi des lignes qui sont dans l'ancien, mais pas dans le nouveau.

Spreadsheet compare par rapport au numéro de la ligne.
J'aimerai lui dire de comparer a partir de la première colonne (qui est un identifiant unique)

Est-ce possible ?
Merci beaucoup
Afficher la suite 

1 réponse

Messages postés
5375
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
5 décembre 2019
358
0
Merci
Bonjour Ciluea

Il faut commencer par mettre tous les identifiants sur la base 1 et 2

Sur la feuille Base 1 :

Contrôler la présence de l'identifiant sur la base 1 par rapport à la base 2 mettre cette formule dans une colonne vide et la tirer vers le bas

=SIERREUR(RECHERCHEV(A1;BASE2!A:A;1;0);"absent")

Sur la feuille Base 2 :

contrôler la présence de l'identifiant sur la base 2 par rapport à la base 1 mettre cette formule dans une colonne vide et la tirer vers le bas

=SIERREUR(RECHERCHEV(A1;BASE1!A:A;1;0);"absent")

Quand les 2 bases on le même nombre de lignes
on peut après trie à l'identique comparer les différentes colonnes et voir les écarts sur une 3 feuilles mettre cette formule

=SI(BASE1!A1=BASE2!A1;"";"différence")

les cellules qui auront le mot différence seront à vérifier
Ciluea
Messages postés
2
Date d'inscription
jeudi 25 janvier 2018
Statut
Membre
Dernière intervention
25 janvier 2018
-
Salut Philou,
Merci pour ton aide

J'ai fait ce que tu as dit avec les formules SIERREUR/Recherche V.

Par contre je me suis arrêtée avant la formule SI car je ne comprend pas bien comment cette formule va me permettre de comparer mes 50 colonnes?

Pour te donner un peu de contexte, mes deux fichiers sont des bases RH/salariés.

Grace a ta formule, j'ai réussi a identifier :
-> J'ai 51 nouvelles lignes (nouveaux salariés qui n'étaient pas dans le fichier de janvier 2017
-> J'ai 37 salariés sortis (qui étaient présents en 2017 mais qui ne sont plus dans mon fichier de janvier 2018)

J'ai besoin de laisser ces lignes dans mes tableaux mais je n'ai pas besoin de les comparer

Ce qui m'intéresse ce sont les autres lignes (salariés présents dans les deux tableaux) je veux savoir ce qui a changé
(j'ai 50 colonnes a comparer)

Si je fais =SI(BASE1!A1=BASE2!A1;"";"différence")

Il ne compare que la première colonne
Mais si quelqu'un a changé d'adresse (Colonne 48) comment vais-je le voir ?
Merci d'avance!
PHILOU10120
Messages postés
5375
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
5 décembre 2019
358 -
j'aurai dû préciser il faut mettre la formule en A1 et tirer celle-ci sur les 50 colonnes
et après sélectionner les formule de la ligne 1 et la tirer vers le bas