Menu

Fonction SOMME.SI.ENS avec hypothèses

Vero - 19 janv. 2018 à 16:28 - Dernière réponse :  Vero
- 12 févr. 2018 à 12:03
Bonjour,

Je suis en train de construire un tableau de bord pour l'année 2018 et je souhaiterai l'automatiser au fur et à mesure des nouvelles entrées de mon fichier source.

Voici joint le fichier source: https://www.cjoint.com/c/HAtpBI2upQM

Je vous ai indiqué la fonction d'exemple que je reporte dans mon tableau de bord :
=SOMME.SI.ENS(E:E;C:C;">=01/01/17";C:C;"<=31/01/17")
Elle me convient pour la plupart des cas mais n'ai plus valide lors de la notion "Fact. Partielle" de la colonne F où il faut que je fasse le calcul à la main car le montant partiel n'est pas renseigné (et je ne le souhaite pas, je veux le faire à la main- il ne s'agira que de moins de 5 cas dans l'année)

Pour cela, je souhaiterai obtenir un avertissement du genre : si colonne F ne comprend pas "Fact. Partielle", alors calcul de la SOMME.SI.ENS, sinon inscrire "calcul manuel".
J'ai essayer d'inclure la fonction somme.si.ens dans une fonction SI mais ça ne fonctionne pas.

D'autre part, je souhaiterai sélectionner modifier la plage de mes colonnes sélectionnées par une colonne entière mais à partir de la ligne 5 (car j'ai souvent un entête de tableau qui pourrait parasiter le calcul). Je ne veux pas sélectionner une plage nominative de la colonne car je ne connais pas l'exact longueure de mon futur tableau. Et que si j'indique C5:C150, ça restera figé et mes lignes au delà de 150 ne seront pas prises en compte.

Merci d'avance pour vos précieux conseils.
Afficher la suite 

Votre réponse

10 réponses

diablo13800 1269 Messages postés jeudi 2 juillet 2015Date d'inscription 20 juillet 2018 Dernière intervention - Modifié par diablo13800 le 19/01/2018 à 16:32
0
Merci
Bonjour,

Il vous faut une fonction si pour ça:
Si(F2="Fact. Partielle";"Calcul manuel";SOMME.SI.ENS(E:E;C:C;">=01/01/17";C:C;"<=31/01/17"))

De plus les entête ne parasite pas les calcul puisque ce ne sont pas des chiffres. Il ne devrait pas y avoir de problème a mettre "F:F" par exemple

Avec cela vous devrait avoir ce que vous voulez



A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
diablo13800 1269 Messages postés jeudi 2 juillet 2015Date d'inscription 20 juillet 2018 Dernière intervention - 22 janv. 2018 à 11:05
Bonjour,

Après quelque test, essayé avec cette formule:

=SOMMEPROD((F3:F150="Facturé")*(MOIS(C3:C150)=1)*E3:E150)

Pour Février remplace le 1 pas 2 après le test du mois etc...

Cette formule calcul les montants des facturé.

Vous pouvez tenter avec celle-ci sinon ... beaucoup plus longue ( il doit y avoir une plus simple bien sur :) )

=SI(SOMMEPROD((F3:F150="Facturé")*(MOIS(C3:C150)=1)*E3:E150)<SOMMEPROD((MOIS(C3:C150)=1)*E3:E150);"Calcul a la main";SOMMEPROD((F3:F150="Facturé")*(MOIS(C3:C150)=1)*E3:E150))

Non il n'est pas possible de faire un E5:E ou une autre technique du genre pour dire " tu commences a tel case et tu fini a la fin" Soi il prend toute la colonne (E:E ) Soit qu'une partie (E5:E2500 par exemple)
Bonjour,

Merci pour la réponse.
La seconde formule fonctionne parfaitement, peut importe la longueur ça me va :)

Encore une toute petite question à ce sujet, je fais aussi un reporting par semaine, en plus du mensuel.
J'ai bien compris qu'il fallait changer le numéro de mois pour la somme prod que tu m'as proposé, mais comment indiquer une plage de date.
Ex : C:C;">=15/01/17";C:C;"<=28/01/17"
diablo13800 1269 Messages postés jeudi 2 juillet 2015Date d'inscription 20 juillet 2018 Dernière intervention - 22 janv. 2018 à 14:16
Bonjour,

La formule semaine existe a la place de mois:)
ce qui pourrait donner :

=SI(SOMMEPROD((F3:F150="Facturé")*(NO.SEMAINE(C3:C150)=1)*E3:E150)<SOMMEPROD((NO.SEMAINE(C3:C150)=1)*E3:E150);"Calcul a la main";SOMMEPROD((F3:F150="Facturé")*(NO.SEMAINE(C3:C150)=1)*E3:E150))
C'est tout parfait !!
Merci Merci Merci
Ça m'a bien aidé
diablo13800 1269 Messages postés jeudi 2 juillet 2015Date d'inscription 20 juillet 2018 Dernière intervention - 22 janv. 2018 à 14:21
Vous risquez juste d'avoir un problème dans le cas ou vous mettez Janvier 2017 et Janvier 2018 ... les deux seront considéré égaux et donc tout deux comptabilisé...

Vous pouvez rajouter Année(C3:C150)=2017 dans la formule Sommeprod ( de la même manière que les autres et donc en 3 fois )
Commenter la réponse de diablo13800
0
Merci
Bonjour, l'ajout de la fonction ANNEE fonctionne parfaitement bien avec la fonction MOIS. Par contre, les numéros de semaine ne fonctionnement pas avec ou sans l'ajout de ANNEE. Comment faire pour les numéros de semaine ?
Commenter la réponse de Vero