Menu

Formule excel trop compliquée pour moi :-) [Résolu]

Romu - 10 janv. 2018 à 13:41 - Dernière réponse : Vaucluse 21901 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention
- 11 janv. 2018 à 10:59
Bonjour,

Ma cellule A1 est en format date (exemple mercredi10 janvier 2018). Je voudrais insérer une formule en B1 pour que si il s'agit d'un lundi, mardi, mercredi ou jeudi la réponse soit 8h00 par contre si c'est un vendredi 6h et finalement un samedi ou dimanche 0h.
Quelqu'un peut il m'aider? :-(
Afficher la suite 

4 réponses

Répondre au sujet
0
Utile
3
Salut, j'ai réussi à faire ça en utilisant en A2 la fonction JOURSEM(A1) qui renvoit 1 pour dimanche, 2 pour lundi ... 7 pour samedi, puis tu introduis un : =SI.CONDITIONS(A2=2;"8h00";A2=3;"8h00";A2=4;"8h00";A2=5;"8h00";A2=6;"6h";A2=7;"0h";A2=1;"0h")

ça marche chez moi sur libreoffice math et ça devrait marcher sur Excel
Vaucluse 21901 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 10 janv. 2018 à 14:20
Bonjour

pour avoir des jours de semaine qui commence à 1 le undi:

=JOURSEM(cellule;2)

et donc la formule:

=SI(JOURSEM(cell;2)<5;8/24;SI(JOURSEM(cell;2)=5;6/24;0))

devrait faire l'affaire dans une cellule formatée en hh:mm

crddmnt
Romu239 3 Messages postés mercredi 10 janvier 2018Date d'inscription 28 février 2018 Dernière intervention - 11 janv. 2018 à 10:44
Merci C'est parfait :-)
Vaucluse 21901 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 11 janv. 2018 à 10:59
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Oxynium