Menu

Formule SI excel [Résolu]

Lau - 30 déc. 2017 à 10:01 - Dernière réponse : Vaucluse 21882 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 avril 2018 Dernière intervention
- 30 déc. 2017 à 15:45
Bonjour,
Dans le cadre d'un projet de communication, je dois réaliser une fiche excel pour savoir quel pourcentage de remise je doit donner au client par rapport à leur CA.
si le CA est au dessus de 3000 € = 2% de remise
si le CA est compris entre 1000 et 3000 = 1%
sinon rien
3000 = P3 et 1000 =P4
par exemple M5= 2900
La formule que j'ai faites est donc :
=SI(M5>=$P$3;"2%";SI($P$4<=M5<$P$3;"1%";""))
Mais celle-ci ne marche pas car elle affiche rien alors qu'elle devrait afficher 1%
Est ce que quelqu'un pourrait m'aider s'il vous plait ?
Afficher la suite 

4 réponses

Répondre au sujet
Vaucluse 21882 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 avril 2018 Dernière intervention - 30 déc. 2017 à 10:07
0
Utile
2
Bonjour
  • 1°) ne placez pas les valeurs % entre guillemets
  • 2° vous écrivez M5 plus grand que P3 donc 3000 ok mais ensuite vous écrivez P4<=M5 donc M5 plus grand que 1000 ce qui revient au précédent


écrivez:
=SI(M5>=$P$3;2%;SI(M5>=$P$4;1%;"")

(Excel s'arrête à la 1° condition remplie et donc si M5>P3 ne lit pas le reste de la formule

crdlmnt
Merci beaucoup pour votre réponse, celle-ci fonctionne
Bonne journée
Vaucluse 21882 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 avril 2018 Dernière intervention - 30 déc. 2017 à 15:45
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse
Patrice33740 6799 Messages postés dimanche 13 juin 2010Date d'inscription 19 avril 2018 Dernière intervention - 30 déc. 2017 à 11:09
0
Utile
Bonjour Lau,
Bonjour Vaucluse,

J'ajouterais qu'Excel n'accepte pas (au sens mathématique) cette syntaxe :
=SI($P$4<=M5<$P$3;"1%";"")

Il calcule le résultat de $P$4<=M5 et obtient un booléen VRAI ou FAUX, ensuite il teste si ce booléen est <$P$3.
Le résultat ne correspond donc pas à M5 supérieur ou égal à P4 et M5 inférieur à P3
Commenter la réponse de Patrice33740