Menu

Compter des cellules selon differents critères [Fermé]

Messages postés
11
Date d'inscription
mercredi 19 avril 2017
Statut
Membre
Dernière intervention
20 décembre 2018
-
Bonjour, je souhaiterais compter des cellules contenant du texte, mais que le résultat obtenu soit egal à 1 quelque soit le nombre de cellules compter. la capture du tableau joint devrait etre plus claire que mes explications.

En gros, je voudrais prendre en considaration les cellules contenant des X, au minimum une, sans pour autant les compter,.
exemple de la ligne de O307 à S307, quelques soit le nombre de X contenu, le résultat en Y 307 soit egal à 1 et non pas 2 comme c'est le cas actuellement.

La fonction que j'utilise en Y307 est le suivant :
=SOMMEPROD(($O$307:$S$307="x")*($T$307=""))

Mais bon ca ne marchepas selon ce que je veux obtenir.

Merci de vos réponses.






Afficher la suite 

2 réponses

Messages postés
608
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
24 mai 2019
59
0
Merci
Bonjour

Peut-être comme ça?

=SIERREUR(NB.SI(A1:A100;"x")/NB.SI(A1:A100;"x");0)

Slts
Merci de la réponse mais cela ne fonctionne pas code erreur 511
Messages postés
1663
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
4 mai 2019
293
0
Merci
Salut,

En combinant les fonctions
NB.SI(plage; critères)
et
SI(test_logique; valeur_si_vrai; [valeur_si_faux])
, on devrait avoir quelque chose du genre :
=SI(NB.SI($O$307:$S$307;"x") > 0; 1 ; 0)


:)
Merci cela fonctionne impeccablement. Super. Bravo à toi.