Menu

Formule pas simple [Résolu]

gigipong 11 Messages postés samedi 27 avril 2013Date d'inscription 21 mai 2018 Dernière intervention - 2 déc. 2017 à 17:31 - Dernière réponse : gigipong 11 Messages postés samedi 27 avril 2013Date d'inscription 21 mai 2018 Dernière intervention
- 2 déc. 2017 à 18:19
Bonjour,
je viens solliciter quelqu'un pour m'aider à résoudre une formule qui pour moi, n'est pas simple.
pour chaque tranche d'écart de points entre deux joueurs, existe une valeur de handicap.
je voudrais que cette formule calcule l'écart entre les points de 2 joueurs (exemple : 1110 et 1430, donc 320 points = handicap : 14) et place cette valeur dans la case correspondante.
sous-entendu que si les joueurs sont inversés (à cause du tirage au sort), la valeur doit être -14.

tableau :


merci de votre aide.
Afficher la suite 

Votre réponse

4 réponses

via55 9435 Messages postés mercredi 16 janvier 2013Date d'inscription 18 juillet 2018 Dernière intervention - 2 déc. 2017 à 17:47
0
Merci
Bonjour gigipong

un exemple : http://www.cjoint.com/c/GLcqVyNN38k

Cdlmnt
Via
gigipong 11 Messages postés samedi 27 avril 2013Date d'inscription 21 mai 2018 Dernière intervention - 2 déc. 2017 à 18:11
merci beaucoup, cela répond parfaitement à mon souhait.
Commenter la réponse de via55
gbinforme 15097 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 23 juin 2018 Dernière intervention - 2 déc. 2017 à 17:52
0
Merci
Bonjour,

Avec le résultat des joueurs en A1 et B1, je te propose cette formule qui devrait résoudre ton problème :
=SI(A1<B1;-1;1)*CHOISIR(EQUIV(ABS(A1-B1);{0;101;201;301;401;501};1);0;6;11;14;17;19)

Tu auras le handicap de A1 et pour avoir celui de B1 tu inverses l'opération :
=SI(B1<A1;-1;1)*CHOISIR(EQUIV(ABS(B1-A1);{0;101;201;301;401;501};1);0;6;11;14;17;19)

gigipong 11 Messages postés samedi 27 avril 2013Date d'inscription 21 mai 2018 Dernière intervention - 2 déc. 2017 à 18:19
merci de m'avoir aidé, les deux réponses me vont bien.
Commenter la réponse de gbinforme