Compter les cellules contenants des chiffres dans une plage [Résolu/Fermé]

Signaler
-
 MM -
Bonjour,

Ma feuille Excel contient des celulles avec des textes et d'autres avec des chiffres pourrais-je avoir une formule pour compter le nbre de cellule contenants des chiffres? avoir le nombre de chiffres contenu dans une plage par exemple.


Merci

2 réponses

Messages postés
24899
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 février 2020
5 044
Bonjour
si vos valeurs sont bien numériques et non pas des nombres sous formes de textes:
pour la colonne A:
=SOMMEPROD((ESTNUM(A:A))*1)
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
michel_m
Messages postés
16083
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 février 2020
2 877
Re Vaucluse ;o)

plage B2:E11
=NB(B2:E11)
Vaucluse
Messages postés
24899
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 février 2020
5 044
Re Michel
tiens, voila un truc que je n'utilisait pas du tout!
on en apprend tous les jours , même quand il n'en reste pas beaucoup (des jours!)
crdlmnt
Bonjour,

Par exemple pour la colonne A contenant du texte et des chiffres sous forme numérique:
=NB(A:A)

Cordialement.
Merci à vous !!

ça marche!!!