Menu

Dernière valeur non nulle

fifimilla - 13 nov. 2017 à 16:01 - Dernière réponse : eriiic 21677 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention
- 15 nov. 2017 à 12:22
Bonjour,

j'ai un problème avec les formules excel ,je souhaite déterminer le nombre de jours ou la vente est nulle aprés la dernière vente je joins mon fichier exemple.
merci d'avance.
http://www.cjoint.com/c/GKno4W3BKzD
Afficher la suite 

Votre réponse

11 réponses

f894009 13152 Messages postés dimanche 25 novembre 2007Date d'inscription 23 juin 2018 Dernière intervention - 13 nov. 2017 à 16:48
0
Merci
Bonjour,

une fonction perso:
http://www.cjoint.com/c/GKnpWjb35jf
merci beaucoup le problème est réglé
Commenter la réponse de f894009
eriiic 21677 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 13 nov. 2017 à 17:09
0
Merci
Bonjour,

par formule :
=COLONNES(B2:W2)-MAX((B2:W2>0)*COLONNE(B2:W2))+1 

formule matricielle à valider avec shift+ctrl+entrée
La formule doit s'entourer de { } si la validation est correcte.
eric
Commenter la réponse de eriiic
fifimilla - 14 nov. 2017 à 11:47
0
Merci
merci la formule fonctionne mais dans le cas ou le commercial ne vend pas au cours des 22 jours le résultat est 23
je comprend pas ou est le problème,mais j'ai testé la solution de f894009 qui fonctionne parfaitement
merci encore une fois
eriiic 21677 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 14 nov. 2017 à 16:25
??????
fiffimilla > eriiic 21677 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 15 nov. 2017 à 08:41
=SI(SOMME(B2:W2);COLONNES(B2:W2)-MAX((B2:W2>0)*COLONNE(B2:W2))+1;colonnes(B2:W2))
eriiic 21677 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 15 nov. 2017 à 09:42
Bonjour,
C'est bien ce que j'avais compris.
Mais comme dans ton exemple tu voulais 0 dans ce cas...
fiffimilla > eriiic 21677 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 15 nov. 2017 à 11:05
non je voulais 22 jours (nombre de jours ou le commercial n'a rien vendu)
merci encore une fois Eriiic pour ton aide
eriiic 21677 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 15 nov. 2017 à 12:22
J'avais pris le fichier de f894009 comme base pour comparer les résultats, qui retournait 0.
Je comprend mieux la confusion que j'ai faite :-)
Commenter la réponse de fifimilla