Menu

Formule [Résolu]

Alex - 10 nov. 2017 à 10:24 - Dernière réponse : Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention
- 10 nov. 2017 à 13:38
Bonjour,

Je recherche une formule pour permettre de faire comprendre à Excel que si un mot dans une colonne et également présent dans une autre colonne, il faut alors compter qu'il y a un mot en commun et non deux mots (NB.SI compte deux mots).
J'espère être assez compréhensif, n'hésitez pas à me demander des précisions !
D'avance, merci !

Afficher la suite 

Votre réponse

7 réponses

Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 10 nov. 2017 à 10:34
0
Merci
Bonjour
compréhensif on ne sait pas, mais compréhensible, pas tout à fait à défaut de connaitre exactement vos données
on essaie avec

=SI(NB.SI(plage;"mot")>1;1;0)

mais renverra aussi 1 si vous avez deux fois le mot dans la même colonne

crdlmnt
Commenter la réponse de Vaucluse
0
Merci
Bonjour,
Merci pour votre réponse,
Donc du coup je vais essayer d'être plus clair.

J'ai une colonne (ici I) et une autre colonne (ici J) avec plusieurs options venant d'une liste déroulante (Par exemple : Validée, Refusée, etc.)
Lorsque sur une ligne (ex la ligne 3) et que le mot "Refusée" ressort sur les deux colonnes et sur la même ligne (ex J3 = Refusée et I3 = Refusée) il faut qu'Excel compte l'option "Refusée" comme un seul mot apparaissant et non deux mot. Il faut aussi lui faire comprendre que lorsque l'option "Refusée" ressort sur une autre ligne mais sur une seule colonne (par exemple I5 = Refusée et que le J5 = Mise à jour) ou le contraire, il faut aussi compter "Refusée" comme un seul mot apparaissant.
Voilà, j'espère avoir été un peu plus clair.
Merci d'avance !
Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 10 nov. 2017 à 11:21
Ben, c'est ce que propose en fait,on ? à tirer sur la hauteur de la plage:
si on commence en ligne "
=NB.SI(I3:J3;"Refusée")>1;1;0)

ou plus simplement, (mais je ne sais encore pas ce que vous voulez si le mot doublé n'est pas n'est pas "refusée")

=SI(I5=J5;1;0)

CRDLMNT
Alors, la deuxième formule marche bien pour le cas du mot "Refusée" qui apparaît sur deux lignes par contre maintenant, j'aimerais rajouter aussi le fait que si "Refusée" apparaît sur une seule ligne, il doit être aussi compter comme un.
Soit : =SI(I5=J5;1;0) pour la première étape et rajouter à la suite le deuxième cas, comment s'y prendre?
Merci d'avance.
Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention > Alex - 10 nov. 2017 à 12:02
Re

alors
pour placer 1 exclusivement en ligne quand le mot refusée apparaît

=NB.SI(I5:J5;"Refusée");1;0)

ou si vous voulez spécifier 1 en cas de mot autre que refusée dans les deux colonnes:

=SI(OU(NB.SI(I5:J5;"Refusée";I5=J5);1;0)

ctrdlmnt
Commenter la réponse de Alex
0
Merci
Merci pour votre aide !

Bonne journée !
Vaucluse 22239 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 juin 2018 Dernière intervention - 10 nov. 2017 à 13:38
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Alex