Multiplier 2 colonnes sur excel [Résolu/Fermé]

- - Dernière réponse :  kkh - 5 juin 2019 à 08:07
Bonjour,

je cherche à multiplier A1 par D1 puis A2 par D2 etc jusqu'à A40 par D40 et à obtenir le résultat dans une seule cellule sans recréer une colonne supplémentaire.
Une astuce?
grand merci,
Marie


Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
1699
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
9 octobre 2019
426
1
Merci
Bonsoir
Si c'est (A1*D1)+A2*D2)+(A...*D...)
Alors
=SOMMEPROD(A1:A40;D1:D40)

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62597 internautes nous ont dit merci ce mois-ci

Messages postés
11192
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 octobre 2019
1452
0
Merci
Bonjour

=SOMMEPROD((A1:A40)*(D1:D40))

Cdlmnt
Via
Messages postés
50048
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
10898
0
Merci
Bonjour amical à yclik et à Via.
Bonjour à toi, Marie.

Ce n'est pas une astuce qui t'a été fournie, mais deux formules, utilisant chacune la fonction SOMMEPROD ...

Elles donnent évidemment le même résultat, à une différence près :
si tu saisis accidentellement un texte à la place d'une valeur numérique,
avec la syntaxe d'yclik =SOMMEPROD(A1:A40;D1:D40) Excel considérera qu'il y a la valeur zéro dans la cellule ;
avec la syntaxe de Via =SOMMEPROD((A1:A40)*(D1:D40)) Excel signalera l'erreur en affichant comme résultat
#VALEUR!


Cordialement.
0
Merci
Bonjour chers aideurs!
Je vous remercie de vos réponses!
Cela fonctionne!