Menu

Datedif + si [Résolu]

geo34 - 9 nov. 2017 à 10:30 - Dernière réponse :  geo34
- 9 nov. 2017 à 11:27
Bonjour,

Bonjour je veux compter le nombre de jours d'une date1 a une date2:

si date de sortie vide
Date du jour (AQ2) - date accompagnement (AC4)
si non
Date de sortie(AI4) - date d'entré (W4)

=SI(AI4="";(DATEDIF(AQ2-AC4;"D"));(DATEDIF(AI4-W4;"D")))

Ca fonctionne pas, une idée ^^ ?
Afficher la suite 

Votre réponse

9 réponses

M-12 237 Messages postés lundi 22 septembre 2008Date d'inscription 21 juin 2018 Dernière intervention - 9 nov. 2017 à 10:58
0
Merci
Bonjour,
Pourquoi utiliser Datedif
une soustraction entre deux date te donnera le Nb de jour
Ah oui xD

=SI(AZ4="";AQ2-AT4;AZ4-W4)

mais j'ai un résultat improbable 43048, c'est parque si la cellule est vide ça me met 1900 de base ?

Dans se cas la si de base tte mes cellules sont vides mais si elles contienne des donnée c'est bon je peux ajouter si tout vide ="" ?
Vaucluse 22230 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 9 nov. 2017 à 11:19
Bonjour
si vous avez 1900 de base c'est que votre résultat est 0 Excel par défaut affiche le 0 janvier 1900 dans une cellule égale à 0.
vous pouvez masquer ce type de résultat via les options avancées Excel en décochant "afficher un 0 dans les cellules de valeurs nulle"
quant au 43408 c'est probablement le résultat du nombre de jours entre la date de fin et 0, et qui correspond pour Excel en fait à la valeur num de la date de fin
Pour éliminer ça , vous pouvez peut être selon vos besoins écrire:
=SI(OU(AZ4="";AT4=0;AZ4=0);"";AQ2-AT4;AZ4-W4)
crdlmnt
Commenter la réponse de M-12
Mike-31 16173 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 19 juin 2018 Dernière intervention - Modifié par Mike-31 le 9/11/2017 à 11:16
0
Merci
Bonjour,

essaye comme cela
=SI(AI4="";DATEDIF(AC4;AQ2;"D");DATEDIF(W4;AI4;"D"))

ou simplement comme cela
=SI(AI4="";AQ2-AC4;AI4-W4)

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Commenter la réponse de Mike-31
Mike-31 16173 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 19 juin 2018 Dernière intervention - 9 nov. 2017 à 11:19
0
Merci
Re,

43048 correspond à la date d'aujourd'hui 09/11/2017

tu dois avoir un problème de formatage de tes cellules

peux tu anonymiser ton fichier et le mettre à notre disposition
1) Clic sur ce http://cjoint.com/
2) Clic sur Parcourir pour sélectionner ton fichier
3) Clic sur le bouton Créer le lien
4) Un lien en bleu souligné sera généré en haut de page, sélectionne clic droit "Copier"
5) reste plus qu'a le "Coller" dans une réponse avec quelques explications.
Commenter la réponse de Mike-31
0
Merci
Merci pour vos réponses, M-12/Mike-31/Vaucluse.

Je vais réussir a me débrouiller maintenant.

vous êtes au top !
Commenter la réponse de geo34
Mike-31 16173 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 19 juin 2018 Dernière intervention - 9 nov. 2017 à 11:26
0
Merci
Re,

comme tu veux, alors je passe le statut de la discussion en résolu
Commenter la réponse de Mike-31