Menu

Problème formule si et.... [Résolu]

Nulosenformule - 13 oct. 2017 à 13:54 - Dernière réponse : PapyLuc51 1574 Messages postés dimanche 3 mai 2009Date d'inscription 22 juillet 2018 Dernière intervention
- 14 oct. 2017 à 05:44
Bonjour,

je galère de trop car pas trop (du tout même) doué pour les formules. Je sais qu'ils y en a qui adorent ça. Ce n'est vraiment pas mon cas. Voici mon problème :

j'ai :
cellule A1 : 1 cellule B1 : 2 cellule C1 : 3
en dessous, dans 3 autres cellules il y aurait le résultat des formules obtenues.

Je m'explique ça donnerai ça :
1 2 3
P M G

donc la formule pourrait être traduite ainsi :
si cellule A1 est inférieure à B1 et B2 alors P (qui veut dire que c'est le plus petit chiffre parmi les 3), sinon si A1>B1 et >B2 alors G (qui veut dire que c'est le chiffre le plus grand) et (si A1<B1 et >C3) ou (si A1>B1 et <C3 alors M (qui veut dire qu'il s'agit du chiffre situé entre les 2 autres en terme d'échelle de valeur).

J'espère que j'ai bien expliqué.

Du fond du coeur un grand merci d'avance pour ceux qui bosserait sur mon problème.
Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
PapyLuc51 1574 Messages postés dimanche 3 mai 2009Date d'inscription 22 juillet 2018 Dernière intervention - Modifié par PapyLuc51 le 13/10/2017 à 17:15
1
Merci
Bonjour

Une proposition en A2

=SI(MAX($A$1;$B$1;$C$1)=A1;"G";SI(MIN($A$1;$B$1;$C$1)=A1;"P";"M"))

à incrémenter vers la droite jusqu'à C2 en maintenant le clic enfoncé sur la poignée de recopie située sur l'angle inférieur droit de la cellule A2

Cordialement

Merci PapyLuc51 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 22594 internautes ce mois-ci

Nulosenformule - 13 oct. 2017 à 21:31
Super génial, c'est exactement ça, vous êtes trop fort, bravo!

Un grand grand merci à vous vous me sauvez !!!!!

merci merci merci
Nulosenformule - 13 oct. 2017 à 22:14
re,

quand je veux copier cette formule vers le bas cette formule :
=SI(MAX($A$1;$B$1;$C$1)=A1;"G";SI(MIN($A$1;$B$1;$C$1)=A1;"P";"M"))

cela ne change QUE A1 en A2 :
=SI(MAX($A$1;$B$1;$C$1)=A2;"G";SI(MIN($A$1;$B$1;$C$1)=A2;"P";"M"))

comment faire pour arriver à ceci ?
=SI(MAX($A$2;$B$2;$C$2)=A2;"G";SI(MIN($A$2;$B$2;$C$2)=A2;"P";"M"))

Merci
Commenter la réponse de PapyLuc51
Meilleure réponse
PapyLuc51 1574 Messages postés dimanche 3 mai 2009Date d'inscription 22 juillet 2018 Dernière intervention - 14 oct. 2017 à 05:44
1
Merci
Bonjour,

Tu n'avais pas précisé cette intention dans ta question initiale.

Si tu veux recopier la formule vers le bas il faut retirer le blocage des numéros de cellule représenté par le signe $

=SI(MAX($A1;$B1;$C1)=A1;"G";SI(MIN($A1;$B1;$C1)=A1;"P";"M"))


Cordialement

Merci PapyLuc51 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 22594 internautes ce mois-ci

Commenter la réponse de PapyLuc51