Menu

Formule Conditions SI [Résolu]

bgee2000 18 Messages postés vendredi 15 août 2003Date d'inscription 5 avril 2018 Dernière intervention - 10 oct. 2017 à 20:24 - Dernière réponse : bgee2000 18 Messages postés vendredi 15 août 2003Date d'inscription 5 avril 2018 Dernière intervention
- 11 oct. 2017 à 12:47
Bonsoir a tous,
Voilà le probleme:
Colonne A : Valeur alternative de "B" et de "P"
Colonne B : Valeur alternative de "S" et "O"
Colonne C: Si "B" dans la colonne A et "S" (=same) alors la valeur a indiquer = "B" (idem pour P)
ET
Si "O" dans la colonne B: il me faut la lettre "opposé", donc si c'est B, il faut que P apparaisse. (Si c'était un P il faudra retourner la valeur "B")
pourriez vous m'aider a écrire cette formule svp?
merci d'avance,

Bgee

--
Afficher la suite 

Votre réponse

8 réponses

Meilleure réponse
2
Merci
Bonsoir bgee2000,

Je te propose cette formule :

=SI(B1="S";A1;CAR(146-CODE(A1)))

----------------------------

Si A1 et / ou B1 peuvent être vides, utilise plutôt :

=SI(OU(A1="";B1="");"";SI(B1="S";A1;CAR(146-CODE(A1))))

Cordialement

Merci paul 2

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 22595 internautes ce mois-ci

Commenter la réponse de paul
fabien25000 265 Messages postés mercredi 5 octobre 2016Date d'inscription 16 octobre 2017 Dernière intervention - 10 oct. 2017 à 20:45
0
Merci
Bonsoir

=SI(ET(OU(A1="B";A1="P");B1="S");C1="B";SI(ET(A1="B";B1="O");C1="P";SI(ET(A1="P";B1="O");C1="B")))
Raymond PENTIER 46367 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 21 juillet 2018 Dernière intervention - 11 oct. 2017 à 04:09
Attention, Fabien !
C'est dans la cellule C1 que tu écris ta formule et donc que s'affichera le résultat !
Tu aurais dû écrire simplement :
=SI(ET(OU(A1="B",A1="P");"S");"B";SI(ET
(A1="B";B1="O");"P";SI(ET(A1="P";B1="O");"B")))
fabien25000 265 Messages postés mercredi 5 octobre 2016Date d'inscription 16 octobre 2017 Dernière intervention > Raymond PENTIER 46367 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 21 juillet 2018 Dernière intervention - 11 oct. 2017 à 06:39
Trés juste Raymond, je déchiffrais la question en écrivant la formule... ceci dit la formule de Paul est beaucoup beaucoup mieux!
paul > fabien25000 265 Messages postés mercredi 5 octobre 2016Date d'inscription 16 octobre 2017 Dernière intervention - 11 oct. 2017 à 11:03
Bonjour Fabien, merci du retour.
Commenter la réponse de fabien25000
Raymond PENTIER 46367 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 21 juillet 2018 Dernière intervention - 11 oct. 2017 à 04:22
0
Merci
Ma formule, de taille intermédiaire entre les deux premières :
=SI(B1="S";A1;SI(B1="O";SI(A1="B";"P";SI(A1="P";"B";""));""))

Je tiens à féliciter paul pour son astucieuse formule, que les débutants en Excel auront du mal à comprendre, mais qui est courte et efficace !
Bonjour Raymond, merci du retour.
Commenter la réponse de Raymond PENTIER
bgee2000 18 Messages postés vendredi 15 août 2003Date d'inscription 5 avril 2018 Dernière intervention - 11 oct. 2017 à 12:47
0
Merci
Super, ça fonctionne parfaitement, merci raymond (et a tous!)

--
Commenter la réponse de bgee2000