Menu

Fonction nb.si [Résolu]

Nina14s 20 Messages postés mercredi 17 mai 2017Date d'inscription 18 janvier 2018 Dernière intervention - 28 sept. 2017 à 18:09 - Dernière réponse : Nina14s 20 Messages postés mercredi 17 mai 2017Date d'inscription 18 janvier 2018 Dernière intervention
- 29 sept. 2017 à 10:40
Bonjour,

J’ai un tableau, contenant une Colonne indiquant la situation professionnelle, comme suit :
- CDI temps complet
- CDI temps partiel
- CDD temps partiel
- CDD temps complet
- interim

On me demande d’indiquer le nombre de personnes qui ont un CDD et qui sont en intérim.
Il faut choisir plusieurs critères dans la même plage.

Exemple :
Si j’ai :
- 2 personnes en CDD temps partiel
- 1 personnes en CDD temps complet
- 3 personnes en intérim.
Donc je dois avoir un nombre de 6 personnes.

Y a-t-il une formule qui nous permet d’avoir ce résultat ?


Merci d’avance.
Afficher la suite 

Votre réponse

6 réponses

ccm81 8519 Messages postés lundi 18 octobre 2010Date d'inscription 15 juillet 2018 Dernière intervention - Modifié par ccm81 le 28/09/2017 à 18:14
0
Merci
Bonjour

Tes types de contrat en A2:A8, ceci devrait suffire
=NB.SI(A2:A8;"CDD")+NB.SI(A2:A8;"interim")

Cdlmnt
Vaucluse 22429 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 juillet 2018 Dernière intervention - 28 sept. 2017 à 18:23
Bonjour
et salut CCM
moi je ne vois pas tout à fait les choses comme ça
et je les vois même de deux façons différentes

soit la colonne A contient les textes complets, au moins pour les variantes CDD et alors la formule est (sur le principe de la tienne mais en sélectionnant CDD dans les textes)

=NB.SI(A2:A8;"*CDD*")+NB.SI(A2:A8;"intérim")

soit la colonne A contient les textes et la B contient le nombre de contrat de chaque
et donc la formule deviendrait:

=SOMME.SI(A2:A8;"*CDD*";B2:B8)+SOMME.SI(A2:A8;"intérim";B2:B8)

crdlmnt
Raymond PENTIER 46330 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 juillet 2018 Dernière intervention > Vaucluse 22429 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 juillet 2018 Dernière intervention - 28 sept. 2017 à 18:26
Pour moi c'est encore pire : ça ressemble fort à un exercice scolaire, qu'on nous demande de résoudre. D'où ma proposition de filtre ...
Nina14s 20 Messages postés mercredi 17 mai 2017Date d'inscription 18 janvier 2018 Dernière intervention - 29 sept. 2017 à 10:40
Merci ccm81, ta fonction a marché.
Commenter la réponse de ccm81
Raymond PENTIER 46330 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 juillet 2018 Dernière intervention - 28 sept. 2017 à 18:15
0
Merci
Bonjour.

C'est très bizarre comme situation !
Dans quel type d'entreprise as-tu besoin de ce genre de calcul :
Une administration, une association 1901, une grosse société ?

Et tu n'as pas besoin de formule ; il te suffit d'appliquer un filtre !
Commenter la réponse de Raymond PENTIER
Vaucluse 22429 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 juillet 2018 Dernière intervention - Modifié par Vaucluse le 28/09/2017 à 18:53
0
Merci
... et en variante de mon message précédent, pour tout grouper dans une même formule

en inscrivant les mots cherchés pour l'exemple en E1 et E2, pour une liste en A2:A20

cas 1 (compter le nombre de texte):
=SOMMEPROD((NB.SI(A2:A20;"*"&E1:E2&"*")*1))

cas 2 (compter le total des valeurs de B selon les textes en A:
=SOMMEPROD((NB.SI(A2:A20;"*"&E1:E2&"*")*(B2:B20))

crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse