Menu

Fonction MOYENNE.SI [Résolu]

sara-87 60 Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - 14 sept. 2017 à 21:09 - Dernière réponse : Raymond PENTIER 46084 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 19 juin 2018 Dernière intervention
- 15 sept. 2017 à 13:43
Bonjour,

J’ai un petit souci avec la fonction MOYENNE.SI, je voudrais calculer les moyennes mobiles sur 8 heures à condition d’avoir au moins 6 des 8 valeurs.
J’ai essayé de calculer le nombre de valeurs qui sont supérieur a 6 dans une colonne, puis appliquer la fonction MOYENNE.SI pour calculer la moyenne ,mais le résultat du calcul n’était pas correct .
j'ai tout essayé pour trouver une solution mais je ne sais pas d'où vient le problème
si quelqu'un aurait une idée ‼
voici le lien du fichier : GIotf0xcWb3_Moy-8h.xlsx
Merci pour vos réponses
Afficher la suite 

Votre réponse

7 réponses

Patrice33740 6963 Messages postés dimanche 13 juin 2010Date d'inscription 18 juin 2018 Dernière intervention - 14 sept. 2017 à 22:19
0
Merci
Bonjour;

Le lien n'est pas valide !
sara-87 60 Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - 14 sept. 2017 à 22:34
Bonjour ,
voici un autre lien : http://www.cjoint.com/c/GIouGlNO6r3
Merci bcp !!
Commenter la réponse de Patrice33740
ccm81 8488 Messages postés lundi 18 octobre 2010Date d'inscription 18 juin 2018 Dernière intervention - Modifié par ccm81 le 14/09/2017 à 23:07
0
Merci
Bonjour à tous les deux

Pas tout compris,
En D10 essaies ceci pour un calcul s'il y a au moins 6 nombres dans la plage
=SI(NB(B3:B10)>=6;MOYENNE(B3:B10);"err")
ou bien ceci pour un calcul s'il y a au moins 6 nombres dans la plage supérieurs ou égaux à 6
=SI(NB.SI(B3:B10;">=" &6)>=6;MOYENNE(B3:B10);"err")
ou ceci pour un calcul, de la moyenne des nombres de la plage qui sont supérieurs ou égaux à 6
=SI(NB.SI(B3:B10;">=" & 6)>=6;SOMMEPROD((B3:B10>=6)*(B3:B10))/NB.SI(B3:B10;">="&6);"err")

Cdlmnt
Commenter la réponse de ccm81
via55 9324 Messages postés mercredi 16 janvier 2013Date d'inscription 15 juin 2018 Dernière intervention - 14 sept. 2017 à 23:11
0
Merci
Bonjour

Essaie en mettant en C10 :
=SI(NB.SI(B3:B10;">0")>=6;1;0)
et en D10 :
=SI(C10=1;MOYENNE(;B3:B10);"")

Cdlmnt
Via
Commenter la réponse de via55
Raymond PENTIER 46084 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 19 juin 2018 Dernière intervention - 15 sept. 2017 à 02:37
0
Merci
Bonjour à vous tous.

En m'appuyant sur les propositions déjà faites, voici ma solution :
1) Insérer une ligne vide tout en haut (pour avoir 2 cellules B1 et B2 sans valeur numérique)
2) Laisser C3:C7 vides
3) En C8 saisir la formule =MOYENNE(B1:B8)
4) Recopier cette formule vers le bas.
Il ne peut pas y avoir plus simple !
Raymond PENTIER 46084 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 19 juin 2018 Dernière intervention - 15 sept. 2017 à 13:43
C'est vraiment décourageant de chercher à aider, surtout dans le sens de la simplification !
Commenter la réponse de Raymond PENTIER
sara-87 60 Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - 15 sept. 2017 à 13:35
0
Merci
Bonjour à tous,
en fait j'ai essayé la première formule proposée par ccm81 et ça a bien marché .
un grand merci à vous tous pour votre aide et bonne journée à tous
Commenter la réponse de sara-87