Menu

Formule excel [Résolu]

kikouNC69 3 Messages postés mardi 12 septembre 2017Date d'inscription 12 septembre 2017 Dernière intervention - 12 sept. 2017 à 12:25 - Dernière réponse : Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention
- 13 sept. 2017 à 11:33
bonjour,
J'ai besoin d'aide car ne m'en sort pas SVP.

Je souhaite une formule prenant en compte différents critères :
si "1" en cellule B (J'ai une liste de choix de 1 à 11)
ET si (cellule C) le montant est supérieur à x
OU SI (cellule D)la durée est supérieure à x
ou si (cellule E)le différé est supérieur à x
Alors "message d'erreur" sinon rien.

Merci
kikou
Afficher la suite 

Votre réponse

16 réponses

Meilleure réponse
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 12 sept. 2017 à 12:48
1
Merci
Bonjour*
une proposition limitée car il manque la connaissance de votre fichier)

=SI(ET(B1=1;OU(C1>X;D1>X;E1>X));"erreur";"")

X étant bien sur à chaque fois la valeur numérique à ne pas dépasser


par contre on ne sait pas c qu'il faut faire quand B n'est pas 1?

si vous en voulez plus, déposez un fichier avec quelques explications ici:
http://mon-partage.fr
et revenez coller ici le lien créé sur le site

crdlmnt

Merci Vaucluse 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 24265 internautes ce mois-ci

Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention > Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 13 sept. 2017 à 10:39
Je viens de voir la dernière question:
pour éviter l'affichage #N/A deux options:
Si Excel >= 2007, au plus simple:

=SIERREUR(formule complète entre parenthèses );"")

ou sinon, puisque le #N/A s'affiche quand le code est vide:

=SI(B2="";"";formule))

crdlmnt
kikouNC69 > Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 13 sept. 2017 à 11:19
Merci pour toutes ces explications.
Derniere demande : la formule "trop d'argument" ca ne fonctionne pas, il doit me manquer un sigle

=SI(D17="";"";F17>RECHERCHEV(D17;'menu deroulant'!regles;2;0);"erreur type";SI(G17>RECHERCHEV(D17;'menu deroulant'!regles;3;0);"erreur durée";SI(ET(G18>RECHERCHEV(D17;'menu deroulant'!regles;4;0));"erreur différé";"")))

merci
amicalement
kikouNC69 > kikouNC69 - 13 sept. 2017 à 11:25
=SI(D19="";"";SI(F19 ....
j'ai trouvé, ca fonctionne SUPER
Encore un grand merci pour votre aide
Bonne journée
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention > kikouNC69 - 13 sept. 2017 à 11:33
Pas de quoi.
si cela convient, merci de passer le sujet en résolu (sous le titre en haut)
bonne route
crdlmnt
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 13 sept. 2017 à 11:26
essayez ces corrections
et il ne devrait pas être utile de rappeler le nom de feuille avec le nom de la plage
=SI(D17="";"";SI(F17>RECHERCHEV(D17;'menu deroulant'!regles;2;0);"erreur type";SI(G17>RECHERCHEV(D17;'menu deroulant'!regles;3;0);"erreur durée";SI(ET(G18<>"pas de différé";G18>RECHERCHEV(D17;'menu deroulant'!regles;4;0));"erreur différé"))))

=SI(D17="";"";SI(F17>RECHERCHEV(D17;regles;2;0);"erreur type";SI(G17>RECHERCHEV(D17;regles;3;0);"erreur durée";SI(ET(G18<>"pas de différé";G18>RECHERCHEV(D17;regles;4;0));"erreur différé"))))
Commenter la réponse de Vaucluse
DjiDji59430 1974 Messages postés samedi 19 avril 2008Date d'inscription 19 juin 2018 Dernière intervention - 12 sept. 2017 à 12:44
0
Merci
Bonjour,

=si(ou((cellule D)la durée est supérieure à x ;(cellule E)le différé est supérieur à x ;et("1" en cellule B; (cellule C) le montant est supérieur à x ));"erreur";"")

C'est le principe, tu adaptes a ton fichier !

Cdlmnt
kikouNC69 3 Messages postés mardi 12 septembre 2017Date d'inscription 12 septembre 2017 Dernière intervention - 12 sept. 2017 à 13:51
G17 correspond cellule D dans ton ex. G18 à la E, D17 à la B et F17 à la C

La formule donnerait ça dans mon tableau, mais ca ne fonctionne pas car j'ai mis en exemple dans F17 : 15 000 et j'ai le "message erreur" qui s'affiche

=SI(OU((G17>360);(G18>36);ET(D17=1);(F17>150000000));"erreur";"")

Merci de votre aide
DjiDji59430 1974 Messages postés samedi 19 avril 2008Date d'inscription 19 juin 2018 Dernière intervention > kikouNC69 3 Messages postés mardi 12 septembre 2017Date d'inscription 12 septembre 2017 Dernière intervention - 12 sept. 2017 à 15:09
=SI(OU(G17>360;G18>36;ET(D17=1;F17>150000000));"erreur";"")
kikouNC69 > DjiDji59430 1974 Messages postés samedi 19 avril 2008Date d'inscription 19 juin 2018 Dernière intervention - 13 sept. 2017 à 11:30
merci de votre aide, la formule beaucoup plus complexe et résolue
Commenter la réponse de DjiDji59430