Menu

Fonction Somme.Si [Résolu]

christ.lenoir 38 Messages postés mardi 6 juin 2017Date d'inscription 7 septembre 2017 Dernière intervention - 1 sept. 2017 à 21:46 - Dernière réponse :  thierry
- 5 sept. 2017 à 15:41
Bonjour,

J'essai de faire une fonction Somme.Si un peu trop complexe pour moi, peut-être vous pourrez m'aider.
Voici ma formule pour l'instant qui ne marche pas.

=SI(B2="AM";SOMME.SI(D3:AH3;B1;D4:AH4);SOMME.SI(D3:AH3;B1+1;D4:AH4))

Dans la cellule B2 la réponse est soit AM ou PM. (lorsque c'est AM je dois prendre la journée même et lorsque c'est PM je dois prendre la journée suivante)

Dans la cellule B1, c'est la date à laquelle je dois faire ma somme jusqu'à la fin du mois.

De D3 à AH3 sont les jours (de 1 à 31)
De D4 à AH4 sont les chiffres dont je veux faire la somme.

Mon problème est que je ne veux pas seulement la date qui se trouve en B1 mais plutôt de B1 jusqu'à la fin. (ex: B1=28, je veux du 28 au 31 comme somme).
Mais comment faire ??

Merci d'avance

Afficher la suite 

Votre réponse

7 réponses

0
Merci
Bonjour christ.lenoir,

Je te propose cette formule :

=SOMME(DECALER(C4;0;B1+(B2="AM")):AH4)

Cordialement
 
christ.lenoir 38 Messages postés mardi 6 juin 2017Date d'inscription 7 septembre 2017 Dernière intervention - 1 sept. 2017 à 22:03
Ça ne marche pas. Ça me donne #REF ?
thierry > christ.lenoir 38 Messages postés mardi 6 juin 2017Date d'inscription 7 septembre 2017 Dernière intervention - 1 sept. 2017 à 22:11
 
Comme tu as écris : « ex: B1=28 », j'ai pensé que tu mettais seulement 28 en B1.
En fait, tu mets une date complète => correction : mettre JOUR(B1) au lieu de B1.

D'où cette nouvelle formule :

=SOMME(DECALER(C4;0;JOUR(B1)+(B2="AM")):AH4)

Fichier Excel : https://mon-partage.fr/f/1QvPzVw3/
 
Commenter la réponse de thierry
Vaucluse 22234 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 21 juin 2018 Dernière intervention - 2 sept. 2017 à 14:49
0
Merci
Bonjour
reste quelque chose de pas très clair dans votre demande
vous dites je compte les "AM" et même les "PM" suivants?
mais ils sont où dans vos données
pour éclaircir, déposez un modèle de vos données (sans confidentielles) sur:
http:mon-partage.fr
et revenez coller ici le lien créé sur le site
(avec quelques explications rajoutées dan le fichier si possible)
à vous lire
crdlmnt
Commenter la réponse de Vaucluse
0
Merci
Bonjour christ.lenoir,

Dans ton énoncé de départ, tu avais écris :

« Dans la cellule B1, c'est la date à laquelle je dois faire
ma somme jusqu'à la fin du mois. »

Ensuite, tu as écris :

« (ex: B1=28, je veux du 28 au 31 comme somme) »

J'ai donc pensé qu'en B1, tu mettais seulement le jour du mois :
28 et pas par exemple 28/08/2017.

La 1ère formule que je t'ai donnée marche pour 28 :

=SOMME(DECALER(C4;0;B1+(B2="AM")):AH4)

2ème formule, pour une date complète telle que 28/08/2017 :

=SOMME(DECALER(C4;0;JOUR(B1)+(B2="AM")):AH4)

Fichier Excel modifié : https://mon-partage.fr/f/1QvPzVw3/

Cordialement
 
christ.lenoir 38 Messages postés mardi 6 juin 2017Date d'inscription 7 septembre 2017 Dernière intervention - 5 sept. 2017 à 15:32
Bonjour à tous,

Désolé pour les infos pas très clair... C'était effectivement le 28 pour une date complète. J'en suis arrivé avec cette formule qui fonctionne bien :
=SOMME(DECALER(D4;0;SI($B$2="AM";$B$1-1;$B$1)):AI4)

Je n'avais jamais utilisé la formule décaler alors je ne savais pas trop comment elle marchait, mais maintenant j'ai pu l'adapter à ma situation.

Merci encore
thierry > christ.lenoir 38 Messages postés mardi 6 juin 2017Date d'inscription 7 septembre 2017 Dernière intervention - 5 sept. 2017 à 15:41
 
Bonjour christ.lenoir,

Tu peux faire plus simple :

=SOMME(DECALER(D4;0;B1-(B2="AM")):AI4)

Ceci est pour 28 ; si c'est pour une date complète
telle que 28/08/2017, ça devrait plutôt être :

=SOMME(DECALER(D4;0;JOUR(B1)-(B2="AM")):AI4)

Cordialement
 
Commenter la réponse de thierry