Menu

Titre colonne dans tableau [Résolu]

petitspieds78 2 Messages postés mardi 4 août 2015Date d'inscription 12 septembre 2017 Dernière intervention - 17 août 2017 à 10:20 - Dernière réponse : petitspieds78 2 Messages postés mardi 4 août 2015Date d'inscription 12 septembre 2017 Dernière intervention
- 12 sept. 2017 à 14:22
Bonjour,

Sur excel 2010, je souhaiterais ajouter dans le tableau, le titre de la colonne correspondant à la première case non vide d'une ligne.

Voici un exemple de ce que je souhaierais :

https://img-19.ccm2.net/By3gDd78xh9VXp0_QYBhaKeNLtE=/6c8f3607a9244dff9bdfdacc7831fcc5/ccm-ugc/test_excel.jpg


Je ne maîtrise pas VBA donc si la solution pouvait être assez simple.
Quoi qu'il en soit, j'essaierai toutes les solutions.

Merci d'avance pour votre aide.
Afficher la suite 

Votre réponse

2 réponses

Vaucluse 22035 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 mai 2018 Dernière intervention - Modifié par Vaucluse le 17/08/2017 à 11:11
0
Utile
Bonjour
voyez avec cette formule en B2, à tirer sur la hauteur

=SIERREUR(INDEX($A$1:$O$1;PETITE.VALEUR(SI($C2:$O2>0;COLONNE($C$1:$O$1));1));"")
notes:
  • cette formule est matricielle est doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées

(elle s'affiche automatiquement entre accolades dans la barre de formule)
  • les adresses de champ commencent en A pour le code INDEX en C pour les autres
  • fonctionne à condition que les autres cellules de la ligne soient vides sans formules


crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse
petitspieds78 2 Messages postés mardi 4 août 2015Date d'inscription 12 septembre 2017 Dernière intervention - 12 sept. 2017 à 14:22
0
Utile
Merci pour votre réponse.
Effectivement cette formule répond à mes attentes.
Cordialement
Commenter la réponse de petitspieds78