Menu

Pourquoi cet algorithme est faux ? [Fermé]

theniet - 6 août 2017 à 00:32 - Dernière réponse : Whismeril 11785 Messages postés mardi 11 mars 2003Date d'inscriptionContributeurStatut 17 juillet 2018 Dernière intervention
- 6 août 2017 à 09:00
Bonjour, pour quoi
cet algo - palindrome est faux ?

algo mot_palindrome

variables n,x,y : entier
mot : chaine

debut
ecrire("entrer un mot : ")
lire(mot)
n:=len(mot) //longueur de mot
x:=0
y:=1
pour i=1 à n/2
si milieu(mot,i,1)=milieu(mot,n-i+1,1) alors
x:=1
sinon
y:=0
finsi
finpour

si y:=0 alors
ecrire("Bravo! ce mot est un palindrome")
sinon
ecrire("Désolé, ce mot n'est pas un palindrome")
finsi
fin





Afficher la suite 

2 réponses

bendrop 7273 Messages postés jeudi 30 juin 2005Date d'inscriptionContributeurStatut 18 juillet 2018 Dernière intervention - Modifié par bendrop le 6/08/2017 à 00:52
0
Merci
Bonsoir,

Merci d'utiliser les balises afin d'être lisible et de ne pas mettre votre pseudo comme titre.

variables n,x,y : entier 
mot : chaine 

debut 
ecrire("entrer un mot : ") 
lire(mot) 
n:=len(mot) //longueur de mot 
x:=0 
y:=1 
pour i=1 à n/2 
si milieu(mot,i,1)=milieu(mot,n-i+1,1) alors 
x:=1 
sinon 
y:=0 
finsi 
finpour 

si y:=0 alors 
ecrire("Bravo! ce mot est un palindrome") 
sinon 
ecrire("Désolé, ce mot n'est pas un palindrome") 
finsi 
fin 


Bav.
Whismeril 11785 Messages postés mardi 11 mars 2003Date d'inscriptionContributeurStatut 17 juillet 2018 Dernière intervention - 6 août 2017 à 09:00