Menu

Formule "si" cellule contient tel ou tel texte [Résolu/Fermé]

Messages postés
4
Date d'inscription
jeudi 27 juillet 2017
Dernière intervention
19 septembre 2017
- - Dernière réponse :  Bryan - 9 août 2018 à 08:53
Bonjour à toutes et tous,

Je galère depuis plusieurs jours et n'ai trouvé aucune réponse sur les forums.

Voilà le problème:
J'ai en colonne A du texte (par exemple NOM PRENOM)
Je voudrais en colonne B mettre une formule qui me donne un résultat en fonction d'une partie du texte de A.
Exemple: si A1 contient "Fabien" ou "Franck" ou encore d'autres prénoms (environ 10 possibilités), alors ça me renvoie "élève", autrement, rien.

Suis-je assez clair pour que quelqu'un puisse m'aider ?

Merci d'avance pour vos tuyaux





Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
16685
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 décembre 2018
4
Merci
Bonsoir,

Une formule parmi d'autres

=SI(OU(NB.SI(A2;"*franck*");NB.SI(A2;"*michel*");NB.SI(A2;"*fabien*"));"élève";"")

à toi d'ajouter des NB.SI(A2;"*franck*") sans oublier les étoiles
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...

Dire « Merci » 4

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM a aidé 33834 internautes ce mois-ci

Tonio5933
Messages postés
4
Date d'inscription
jeudi 27 juillet 2017
Dernière intervention
19 septembre 2017
-
Merci Mike !
Je viens de tester, et visiblement ça fonctionne.
Je termine ma formule avec tout ce dont j'ai besoin et reviens vers vous si je retombe en panne !

Encore merci
Mike-31
Messages postés
16685
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 décembre 2018
> Tonio5933
Messages postés
4
Date d'inscription
jeudi 27 juillet 2017
Dernière intervention
19 septembre 2017
-
Re,

Ok pas de problème, de toute façon si ton problème est résolu n'oublie pas de mettre le statut de la discussion en résolu.
Cordialement
Bonjour,

J'ai besoin d'obtenir une formule:

Si dans ma colonne A réponse "NON" donner en colonne C la valeur écrite d'une cellule en colonne B.

Merci à tous
Messages postés
2152
Date d'inscription
samedi 19 avril 2008
Dernière intervention
13 décembre 2018
0
Merci
Bonjour,

Quelle est la forme exacte de ton texte ? valable pour toute la colonne nom/prenom ?
Et tu ne peux pas dissocier le nom du prénom en 2 colonnes ??

Bonjour ,

Joins un fichier-test, (avec TOUTES les explications et les résultats souhaités) ou mieux, si c'est possible, le fichier concerné, c'est plus commode pour les intervenants.

1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.