Menu

Afficher objet dans cellule si condition respectée [Résolu]

André Roussel - 17 juil. 2017 à 09:45 - Dernière réponse :  André Roussel
- 17 juil. 2017 à 11:53
Bonjour,

J'aimerais afficher dans une cellule des flèches (montantes ou descendantes), mais celles-ci ne s'afficherait que si une condition dans la formule de la cellule est respectée.
Je donne un exemple

Valeur Semaine actuelle Valeur semaine précédente Evolution
8 7 (Flèche qui descend)
5 9 (Flèche qui monte)
7 4 (Flèche qui descend)

Je me doute bien que cela a à voir avec une formule du style : Si (B1>A1) mais je ne sais pas mettre les flèches ensuite.
Remarque : Je n'ai besoin de le faire que sur quelques ligne donc je n'ai pas besoin d'étirer la colonne pour que cela se remplisse automatiquement; J'ai juste besoin de la formule au niveau d'une seule cellule.

Merci d'avance.
Bien cordialement,

André Roussel



Afficher la suite 

4 réponses

Répondre au sujet
Vaucluse 21903 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 27 avril 2018 Dernière intervention - 17 juil. 2017 à 11:11
+1
Utile
1
Bonjour
voyez avec cette solution

1° formatez vos cellules en police "wingdings"

pour montants / descendant / nul de A1 à B1:
la formule:

=SI(A1<B1;CAR(233);SI(A1>B1;CAR(234);SI(A1=B1;CAR(232)&CAR(231);"")))

ou encore sous le même format

=SI(A1<B1;"é";SI(A1>B1;"ê";SI(A1=B1;è&ç;"")))

(ça revient au même )
vous pouvez aussi formater ces flèches avec des mises en forme conditionnelles, rouge, vert , etc.. en utilisant les mêmes formules:

=C1="é"' ou C1="è" etc...

crdlmnt

Cette réponse vous a-t-elle aidé ?  
André Roussel - 17 juil. 2017 à 11:47
Merci beaucoup Vaucluse

Cela fonctionne très bien et est très pratique !
Commenter la réponse de Vaucluse
eriiic 21545 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - Modifié par eriiic le 17/07/2017 à 11:32
+1
Utile
1
Bonjour,

exemple avec une MFC : http://www.cjoint.com/c/GGrjEAlJvko
eric

PS : sélectionner la plage concernée (ici C2:C5) avant d'appliquer la MFC

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Cette réponse vous a-t-elle aidé ?  
André Roussel - 17 juil. 2017 à 11:53
Merci eriic,

Cela fonctionne également, merci beaucoup !
Mêmes si j'ai déjà appliqué la formule de Vaucluse ;)
Commenter la réponse de eriiic