Menu

Comment associer une valeur à un nom dans excel ? [Résolu]

cocodepeche 3 Messages postés mercredi 12 juillet 2017Date d'inscription 13 juillet 2017 Dernière intervention - 12 juil. 2017 à 12:31 - Dernière réponse : cocodepeche 3 Messages postés mercredi 12 juillet 2017Date d'inscription 13 juillet 2017 Dernière intervention
- 13 juil. 2017 à 09:50
Bonjour, Afin de calculer des frais de déplacement, j'ai relevé une liste de villes et les kilométrages associés. Comment afficher automatiquement le kilométrage dans la colonne B lorsque je choisis une ville dans la liste déroulante colonne A ? Merci pour votre aide.
Afficher la suite 

4 réponses

Répondre au sujet
Vaucluse 21878 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 12 juil. 2017 à 12:46
0
Utile
3
Bonjour

votre base de données en feuil1:

_ville en A, distance en B
_édition en feuil2

si on commence en A2
menu déroulant nom de ville en A
km à ressortir en B

=SIERREUR(RECHERCHEV(A2;Feuil1!A:B;2;0);"")

le code si erreur évite l'affichage de #N/A quand A2 est vide, mais n'est applicable qu'à partir de Excel 2007

si antérieur:

=SI(A2="";"";RECHERCHEV(A2;Feuil1!A:B;2;0))

crdlmnt

cocodepeche 3 Messages postés mercredi 12 juillet 2017Date d'inscription 13 juillet 2017 Dernière intervention - 12 juil. 2017 à 13:10
Merci, beaucoup, ça fonctionne ! (J'abuse : Pouvez-vous m'expliquer le "2" et le "0" ?) Très cordialement.
Vaucluse 21878 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention > cocodepeche 3 Messages postés mercredi 12 juillet 2017Date d'inscription 13 juillet 2017 Dernière intervention - 12 juil. 2017 à 16:44
Pas de problème

le 2
RECHERCHEV cherche une valeur dans la 1° colonne d'une plage et ressort celle sur la même ligne dans la,colonne indiqué par le 2
si par exemple vous avez une plage B:X, la formule va chercher la valeur dans la, colonne B et si vous indiquez 2, ressort la valeur en C(2° colonne de B:X) 4 la valeur en D etc...
le 0
c'est un code Excel qui demande à la formule de ne trouver que des valeurs exactes. Cela peut s'écrire aussi....;FAUX)
sans cette info, RECHERCHEV va sélectionner la valeur inférieure la plus proche, à condition que la colonne de recherche soit classée par ordre croissant (Alpha ou num)

et ppur complèter l'info: RECHERCHEH faitb la même chose, mais avec les lignes.

crdlmnt
cocodepeche 3 Messages postés mercredi 12 juillet 2017Date d'inscription 13 juillet 2017 Dernière intervention > Vaucluse 21878 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 13 juil. 2017 à 09:50
MERCI++++ c'est lumineux !
Cela donne bcp de possibilités et va m'être très utile.

Bonne journée.
Commenter la réponse de Vaucluse