Menu

Formule somme.si [Résolu]

Houari100 25 Messages postés samedi 17 août 2013Date d'inscription 9 août 2017 Dernière intervention - 9 juil. 2017 à 11:38 - Dernière réponse : Vaucluse 22048 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 mai 2018 Dernière intervention
- 9 juil. 2017 à 16:04
bonjour
j'ai un problem dans exel avec la formule somme.si mais dans ce cas je veux faire une formule somme.si mais avec 2 critère (N° et DOS_LIV)
N° DOS_LIV NOM_PROD PRE_PROD FIS_PROD BD BT
1 5111106 MOKHTARI BOUDERBALA BENALI 15,00 -
2 5111106 MOKHTARI BOUDERBALA BENALI 20,00 25,00
1 5111106 MOKHTARI BOUDERBALA BENALI 30,00 10,00
1 5111304 BENMAZA FODIL BELKHIER 10,00 -
2 5111304 BENMAZA FODIL BELKHIER - 25,00
3 5111304 BENMAZA FODIL BELKHIER 10,00 10,00
2 5111304 BENMAZA FODIL BELKHIER 30,00 -
1 5111304 BENMAZA FODIL BELKHIER 25,00 40,00

la sollution sans doublons
N° DOS_LIV NOM_PROD PRE_PROD FIS_PROD BD BT
1 5111106 MOKHTARI BOUDERBALA BENALI 45,00 10,00
2 5111106 MOKHTARI BOUDERBALA BENALI 20,00 25,00
1 5111304 BENMAZA FODIL BELKHIER 35,00 40,00
2 5111304 BENMAZA FODIL BELKHIER 30,00 25,00
3 5111304 BENMAZA FODIL BELKHIER 10,00 10,00

et merci
Afficher la suite 

Votre réponse

3 réponses

Vaucluse 22048 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 mai 2018 Dernière intervention - 9 juil. 2017 à 11:50
0
Merci
Bonjour
essayez avec ( à partir de Exceln 2007):

=SOMME.SI.ENS(champ, à sommer;champ des N°;N°;champ des codes;codes)

et avant 2007

=SOMMEPROD((Champ ,des N° =N°)*(champ des codes=codes)*(Champ à sommer))
dans ce dernier cas; bien limiter les champs avec des N° de lignes ( pas de A:A mais par ex: A1:A100)

crdlmnt
Houari100 25 Messages postés samedi 17 août 2013Date d'inscription 9 août 2017 Dernière intervention - 9 juil. 2017 à 11:59
Merci pour ton aide Vaucluse
ca marche bien merci et bonne courage
A biento
Vaucluse 22048 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 mai 2018 Dernière intervention - 9 juil. 2017 à 16:04
OK pas de quoi, je passe en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse